Bug 243728 - sysutils/getssl Update 2.16
Summary: sysutils/getssl Update 2.16
Status: Closed DUPLICATE of bug 244116
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Emanuel Haupt
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2020-01-30 13:00 UTC by MIHIRA Sanpei Yoshiro
Modified: 2020-02-24 18:41 UTC (History)
3 users (show)

See Also:
w.schwarzenfeld: maintainer-feedback? (rainbow)


Attachments
Patch to update to 2.16 (822 bytes, patch)
2020-01-30 13:00 UTC, MIHIRA Sanpei Yoshiro
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description MIHIRA Sanpei Yoshiro freebsd_committer 2020-01-30 13:00:21 UTC
Created attachment 211191 [details]
Patch to update to 2.16

Update to 2.16

2.15
 * issue #453 and #454 Add User-Agent to all curl requests
 * issue #456 Fix shellcheck issues
 * issue #459 Fix missing chain.crt
 * issue #462 Use POST-as-GET for ACMEv2 endpoints
 * issue #464 and #486 "json was blank" (change all curl request to use POST-as-GET)
 * Error and exit if rate limited, exit if curl returns nothing
 * Change domain and getssl templates to v2

2.16
 * issue #473 and #477 Don't use POST-as-GET when sending ready for challenge for ACMEv1
Comment 1 Steve Wills freebsd_committer 2020-01-30 20:27:21 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/113623537
Comment 2 MIHIRA Sanpei Yoshiro freebsd_committer 2020-02-14 05:33:44 UTC
I created newer update request #244116

*** This bug has been marked as a duplicate of bug 244116 ***
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-14 06:19:00 UTC
(In reply to MIHIRA Sanpei Yoshiro from comment #2)

For future issues please update an existing issue summary/patch, rather than open a new/separate issue