Bug 243735 - devel/glib20: Revert SSP_CFLAGS workaround (ports r500819) for qemu-user-static
Summary: devel/glib20: Revert SSP_CFLAGS workaround (ports r500819) for qemu-user-static
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-30 17:28 UTC by Kyle Evans
Modified: 2020-02-20 19:05 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (gnome)


Attachments
svn(1) diff against the ports tree (1.89 KB, patch)
2020-01-30 17:28 UTC, Kyle Evans
koobs: maintainer-approval+
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle Evans freebsd_committer 2020-01-30 17:28:24 UTC
Created attachment 211199 [details]
svn(1) diff against the ports tree

This patch includes unwinding of SSP_CFLAGS for devel/glib20, emulators/qemu-sbruno, emulators/qemu-user-static-devel -- the latter two are "Approved by: emulation (maintainer, kevans)"

- devel/glib20 SSP_CFLAGS were added in r500819.
- emulators/qemu-sbruno SSP_CFLAGS were added in r501032.

Both of these were added to workaround what turned out to be imprecise ordering in libc, which is now fixed in all supported releases as of 11.3-p6, 12.0-p13, 12.1-p2. This patch may need to be delayed slightly to make sure the package builders have caught up to the appropriate patchlevel to ensure we don't end up with broken packages, but I'm told this happens frequently.

Anyone building their own ports will need to ensure they're building against a base of the appropriate patchlevels.
Comment 1 Kyle Evans freebsd_committer 2020-01-31 17:42:09 UTC
This patch in-fact does not need to be delayed- I have confirmed from the 12.0/11.3 builders' logs that they are at the latest patch levels for this.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-04 01:13:02 UTC
Comment on attachment 211199 [details]
svn(1) diff against the ports tree

Approved by: kwm (gnome, maintainer via IRC) [1]
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-04 01:13:28 UTC
Comment on attachment 211199 [details]
svn(1) diff against the ports tree

Approved by: koobs (ports, for emulators/qemu*) [2]
Comment 4 commit-hook freebsd_committer 2020-02-05 16:06:36 UTC
A commit references this bug:

Author: kevans
Date: Wed Feb  5 16:06:32 UTC 2020
New revision: 525281
URL: https://svnweb.freebsd.org/changeset/ports/525281

Log:
  glib20: revert SSP_CFLAGS workaround (ports r500819)

  This was later diagnosed to be a bug in libc, which has since been addressed
  in all supported releases and branches. PORTREVISION is bumped as SSP_CFLAGS
  will change the output.

  The bug was fixed in the following patch levels (FreeBSD-EN-20:01.ssp):
  - 12.1-p2
  - 12.0-p13
  - 11.3-p6

  PR:		243735
  Approved by:	kwm (gnome, maintainer via IRC)
  MFH:		2020Q1

Changes:
  head/devel/glib20/Makefile
Comment 5 commit-hook freebsd_committer 2020-02-05 16:09:38 UTC
A commit references this bug:

Author: kevans
Date: Wed Feb  5 16:09:20 UTC 2020
New revision: 525282
URL: https://svnweb.freebsd.org/changeset/ports/525282

Log:
  qemu-user-static: revert SSP_CFLAGS workaround (ports r501032)

  This was later diagnosed to be a bug in libc, which has since been addressed
  in all supported releases and branches. PORTREVISION is bumped as SSP_CFLAGS
  will change the output, and for consumers of these two ports it is
  imperative that it be rebuilt against the updated libc to avoid high failure
  rates. In testing qemu-user-static-devel failed roughly 60% of the time,
  rendering it unusable as each fork/exec was yet one more chance to fail.

  The bug was fixed in the following patch levels (FreeBSD-EN-20:01.ssp):
  - 12.1-p2
  - 12.0-p13
  - 11.3-p6

  PR:		243735
  Approved by:	koobs (ports)
  MFH:		2020Q1

Changes:
  head/emulators/qemu-sbruno/Makefile
  head/emulators/qemu-user-static-devel/Makefile
Comment 6 Kyle Evans freebsd_committer 2020-02-05 16:14:10 UTC
Committed; thanks!

I intend to MFH both of these to 2020Q1, since the relevant quarterly packages are effectively broken at runtime in a way that consumers can't do anything about.
Comment 7 commit-hook freebsd_committer 2020-02-20 19:02:50 UTC
A commit references this bug:

Author: kevans
Date: Thu Feb 20 19:02:20 UTC 2020
New revision: 526581
URL: https://svnweb.freebsd.org/changeset/ports/526581

Log:
  MFH: r525281

  glib20: revert SSP_CFLAGS workaround (ports r500819)

  This was later diagnosed to be a bug in libc, which has since been addressed
  in all supported releases and branches. PORTREVISION is bumped as SSP_CFLAGS
  will change the output.

  The bug was fixed in the following patch levels (FreeBSD-EN-20:01.ssp):
  - 12.1-p2
  - 12.0-p13
  - 11.3-p6

  PR:		243735
  Approved by:	kwm (gnome, maintainer via IRC)

  Approved by:	ports-secteam (miwi)

Changes:
_U  branches/2020Q1/
  branches/2020Q1/devel/glib20/Makefile
Comment 8 commit-hook freebsd_committer 2020-02-20 19:05:52 UTC
A commit references this bug:

Author: kevans
Date: Thu Feb 20 19:05:03 UTC 2020
New revision: 526582
URL: https://svnweb.freebsd.org/changeset/ports/526582

Log:
  MFH: r525282

  qemu-user-static: revert SSP_CFLAGS workaround (ports r501032)

  This was later diagnosed to be a bug in libc, which has since been addressed
  in all supported releases and branches. PORTREVISION is bumped as SSP_CFLAGS
  will change the output, and for consumers of these two ports it is
  imperative that it be rebuilt against the updated libc to avoid high failure
  rates. In testing qemu-user-static-devel failed roughly 60% of the time,
  rendering it unusable as each fork/exec was yet one more chance to fail.

  The bug was fixed in the following patch levels (FreeBSD-EN-20:01.ssp):
  - 12.1-p2
  - 12.0-p13
  - 11.3-p6

  PR:		243735
  Approved by:	koobs (ports)

  Approved by:	ports-secteam (implicit, runtime fix)

Changes:
_U  branches/2020Q1/
  branches/2020Q1/emulators/qemu-sbruno/Makefile
  branches/2020Q1/emulators/qemu-user-static-devel/Makefile