Bug 243779 - graphics/jp: fix build on aarch64
Summary: graphics/jp: fix build on aarch64
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Only Me
Assignee: Mateusz Piotrowski
URL: http://thunderx1.nyi.freebsd.org/data...
Keywords:
: 244197 (view as bug list)
Depends on:
Blocks: 242312
  Show dependency treegraph
 
Reported: 2020-02-01 15:41 UTC by Mikael Urankar
Modified: 2020-02-24 19:27 UTC (History)
3 users (show)

See Also:
0mp: maintainer-feedback+


Attachments
patch (1.19 KB, patch)
2020-02-01 15:41 UTC, Mikael Urankar
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikael Urankar freebsd_committer 2020-02-01 15:41:09 UTC
Created attachment 211254 [details]
patch

Replace embedded golang-sys by fead79001313 to fix build on aarch64
Comment 1 Mikael Urankar freebsd_committer 2020-02-01 16:05:23 UTC
reported upstream https://github.com/sgreben/jp/issues/22
Comment 2 Mateusz Piotrowski freebsd_committer 2020-02-01 16:11:22 UTC
Thank you! Please feel free to commit! At least in case of my Go ports, those kind of fixes can just get committed---there's no need to go through the hassle of bugzilla.

Cheers!
Comment 3 Mikael Urankar freebsd_committer 2020-02-02 17:33:45 UTC
(In reply to Mateusz Piotrowski from comment #2)
Ok, manu@ will have to review my patch for some time, hence the PR :)
Comment 4 Mikael Urankar freebsd_committer 2020-02-17 18:25:23 UTC
*** Bug 244197 has been marked as a duplicate of this bug. ***
Comment 5 Emmanuel Vadot freebsd_committer 2020-02-21 11:53:47 UTC
Approved-by: manu (mentor)
Comment 6 commit-hook freebsd_committer 2020-02-24 17:53:35 UTC
A commit references this bug:

Author: mikael
Date: Mon Feb 24 17:53:32 UTC 2020
New revision: 527009
URL: https://svnweb.freebsd.org/changeset/ports/527009

Log:
  graphics/jp: Unbreak on aarch64

  Unbreak by pulling in golang.org/x/sys@fead7900131 to fix build on aarch64

  PR:		243779
  Approved by:	0mp, manu (mentor)

Changes:
  head/graphics/jp/Makefile
  head/graphics/jp/distinfo