Bug 243859 - mail/james: Update to 3.4.0
Summary: mail/james: Update to 3.4.0
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2020-02-04 01:21 UTC by Tommy P
Modified: 2020-03-28 03:16 UTC (History)
1 user (show)

See Also:


Attachments
mail/james/Makefile (1005 bytes, patch)
2020-02-04 01:22 UTC, Tommy P
no flags Details | Diff
mail/james/pkg-plist (9.92 KB, text/plain)
2020-02-04 01:23 UTC, Tommy P
no flags Details
Patch to update james to 3.4.0 (52.72 KB, patch)
2020-03-28 03:09 UTC, Tommy P
no flags Details | Diff
Patch to update james to 3.4.0 (52.40 KB, patch)
2020-03-28 03:16 UTC, Tommy P
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tommy P 2020-02-04 01:21:25 UTC
Please update to v3.4.0 since 2.3.2.1 is the 'previous' or perhaps:

*) Create a new port mail/james3 ?
*) Copy current port to mail/james2 and update mail/james ?

Please advise.  TIA.
Comment 1 Tommy P 2020-02-04 01:22:58 UTC
Created attachment 211333 [details]
mail/james/Makefile
Comment 2 Tommy P 2020-02-04 01:23:26 UTC
Created attachment 211334 [details]
mail/james/pkg-plist
Comment 3 Tommy P 2020-03-17 20:47:04 UTC
Please put this on hold as I'm seeing some issues with this version as well as others on the James' users mailing list.
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-18 04:52:09 UTC
@Tommy When proposing change proposals, please include them as a single unified diff file (using svn diff or diff -u)

Thanks!
Comment 5 Tommy P 2020-03-18 05:28:43 UTC
(In reply to Kubilay Kocak from comment #4)

I'll remember that going forward.  Thank you.
Comment 6 Tommy P 2020-03-23 19:33:13 UTC
I've taken a good look at the new version 3.4.0 and see some issues thus far with the dependencies:

log4j (version 1 EOL at end of 2015) - in place replacement available
springframework (v3.2.x EOL at end of 2016) - requires major change in the source code.

There are probably others too.  Due to security risks of EOL software, I don't think this port is viable on ports tree and should be removed.
Comment 7 Tommy P 2020-03-28 03:09:48 UTC
Created attachment 212776 [details]
Patch to update james to 3.4.0
Comment 8 Tommy P 2020-03-28 03:16:07 UTC
Created attachment 212777 [details]
Patch to update james to 3.4.0

Corrected distinfo