Bug 243935 - [NEW PORT] www/annie: Fast, simple and clean video downloader
Summary: [NEW PORT] www/annie: Fast, simple and clean video downloader
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Hiroki Tagato
URL: https://github.com/iawia002/annie
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-06 18:50 UTC by Lewis Cook
Modified: 2020-06-07 06:37 UTC (History)
2 users (show)

See Also:


Attachments
annie-0.9.8.diff (6.40 KB, patch)
2020-02-06 18:50 UTC, Lewis Cook
no flags Details | Diff
annie-0.9.8.log (35.30 KB, text/plain)
2020-02-06 18:50 UTC, Lewis Cook
no flags Details
annie-0.10.1.diff (6.94 KB, patch)
2020-06-05 18:54 UTC, Lewis Cook
no flags Details | Diff
annie-0.10.1.log (30.43 KB, text/plain)
2020-06-05 18:54 UTC, Lewis Cook
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lewis Cook freebsd_committer freebsd_triage 2020-02-06 18:50:21 UTC
Created attachment 211418 [details]
annie-0.9.8.diff

Command-line video downloader written in Go,
supporting over 20 sites and includes features
such as resumable downloads, multiple downloads
and auto-retry.

WWW: https://github.com/iawia002/annie


Testing:
   * No errors reported with portlint, built in Poudriere and
     application works as expected (logs attached).
Comment 1 Lewis Cook freebsd_committer freebsd_triage 2020-02-06 18:50:48 UTC
Created attachment 211419 [details]
annie-0.9.8.log

* Poudriere build log.
Comment 2 Hiroki Tagato freebsd_committer 2020-04-21 02:31:55 UTC
I tried to download the video in the README.md and got the following error.

$ annie 'https://www.youtube.com/watch?v=dQw4w9WgXcQ'
Downloading https://www.youtube.com/watch?v=dQw4w9WgXcQ error:
invalid character ';' after top-level value

Can you check?
Comment 3 Lewis Cook freebsd_committer freebsd_triage 2020-04-21 18:17:22 UTC
(In reply to Hiroki Tagato from comment #2)

During the time of submission it was working as expected. It seems yet again YouTube have broken the pages which would typically be scraped for the relevant metadata, subsequently breaking this functionality. I've found others have faced this similar issue [1]. Until it's addressed upstream there isn't unfortunately much we can do. :(

[1] https://github.com/iawia002/annie/issues/658
Comment 4 Hiroki Tagato freebsd_committer 2020-04-22 07:17:52 UTC
(In reply to Lewis Cook from comment #3)

Thanks for checking with the upstream. If the issue is addressed, please give me a head-up and I will take care of this PR.
Comment 5 Daniel Engberg freebsd_committer 2020-04-22 22:27:44 UTC
Out of curiosity, does it offer anything that youtube-dl (www/youtube_dl) doesn't?
Comment 6 Lewis Cook freebsd_committer freebsd_triage 2020-04-22 22:42:24 UTC
(In reply to daniel.engberg.lists from comment #5)

As far as my understanding goes, youtube_dl is specifically just for YouTube videos and that alone. Whilst annie supports a plethora of other video hosts. In this instance, the YouTube feature of annie is broken although it's other functionality still remains intact. For the other features you can view the full README [1] from the repository. 

[1] https://github.com/iawia002/annie/blob/master/README.md
Comment 7 Daniel Engberg freebsd_committer 2020-04-23 06:20:36 UTC
Dispite it's name it supports a lot more,
http://ytdl-org.github.io/youtube-dl/supportedsites.html
https://github.com/ytdl-org/youtube-dl/tree/master/youtube_dl/extractor

The reason I'm asking is because it seems inferior and it looks (I haven't compared) that all(?) sites are supported by youtube-dl.

Best regards,
Daniel
Comment 8 Lewis Cook freebsd_committer freebsd_triage 2020-04-23 09:41:45 UTC
(In reply to daniel.engberg.lists from comment #7)

To each their own. Some may find more use in one or the other, and one may offer more functionality than the other - and that's absolutely fine.
Comment 9 Lewis Cook freebsd_committer freebsd_triage 2020-04-23 09:47:15 UTC
Plus I don't believe Annie tries to replace youtube_dl, so drawing the distinction between them seems counter intuitive. It's simply another tool available to those who want it's particular range of features.
Comment 10 Daniel Engberg freebsd_committer 2020-04-24 22:24:40 UTC
I think you misunderstood me here, I just tried to understand pros and cons about this software. Either way, the examples in README at least needs to/should work so we'll have to wait for another release or backport a fix before committing imho.
Comment 11 Lewis Cook freebsd_committer freebsd_triage 2020-04-24 22:31:39 UTC
(In reply to daniel.engberg.lists from comment #10)

Gotcha. That's the plan too, as aforementioned until this issue is addressed and resolved upstream there is little point adding this port yet. :)
Comment 12 Lewis Cook freebsd_committer freebsd_triage 2020-06-05 18:54:04 UTC
Created attachment 215278 [details]
annie-0.10.1.diff

* Update to 0.10.1.
Comment 13 Lewis Cook freebsd_committer freebsd_triage 2020-06-05 18:54:23 UTC
Created attachment 215279 [details]
annie-0.10.1.log

* Poudriere testport log.
Comment 14 Lewis Cook freebsd_committer freebsd_triage 2020-06-05 18:55:10 UTC
The latest release (0.10.1) have fixed the remaining issues aforementioned.
Comment 15 commit-hook freebsd_committer 2020-06-07 06:36:18 UTC
A commit references this bug:

Author: tagattie
Date: Sun Jun  7 06:36:04 UTC 2020
New revision: 538144
URL: https://svnweb.freebsd.org/changeset/ports/538144

Log:
  New port: www/annie: Fast, simple and clean video downloader

  Command-line video downloader written in Go, supporting over 20 sites
  and includes features such as resumable downloads, multiple downloads
  and auto-retry.

  WWW: https://github.com/iawia002/annie

  PR:		243935
  Submitted by:	Lewis Cook <vulcan@wired.sh>
  Approved by:	mentors (implicit)

Changes:
  head/www/Makefile
  head/www/annie/
  head/www/annie/Makefile
  head/www/annie/distinfo
  head/www/annie/pkg-descr
Comment 16 Hiroki Tagato freebsd_committer 2020-06-07 06:37:19 UTC
Committed, thanks!