Bug 243948 - dns/knot-resolver: [patch] upgrade to 5.0.1
Summary: dns/knot-resolver: [patch] upgrade to 5.0.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL: https://www.knot-resolver.cz/2020-02-...
Keywords: buildisok
: 243729 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-06 22:06 UTC by Leo Vandewoestijne
Modified: 2020-02-15 18:19 UTC (History)
2 users (show)

See Also:


Attachments
knot-resolver 5.0.1 (8.04 KB, patch)
2020-02-06 22:06 UTC, Leo Vandewoestijne
freebsd: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Leo Vandewoestijne 2020-02-06 22:06:37 UTC
Created attachment 211433 [details]
knot-resolver 5.0.1

This patch will upgrade knot-resolver to 5.0.1
Tested with poudriere on 12.0, amd64 and i386
Comment 1 Leo Vandewoestijne 2020-02-06 22:07:46 UTC
*** Bug 243729 has been marked as a duplicate of this bug. ***
Comment 2 Automation User 2020-02-06 23:37:27 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/115697082
Comment 3 Kurt Jaeger freebsd_committer 2020-02-15 18:19:23 UTC
Committed, thanks!
Comment 4 commit-hook freebsd_committer 2020-02-15 18:19:37 UTC
A commit references this bug:

Author: pi
Date: Sat Feb 15 18:19:16 UTC 2020
New revision: 526235
URL: https://svnweb.freebsd.org/changeset/ports/526235

Log:
  dns/knot-resolver: upgrade 4.2.2 -> 5.0.1

  - for changes from 4.x to 5.x which might cause trouble during upgrades,
    please read:
    https://knot-resolver.readthedocs.io/en/stable/upgrading.html

  PR:		243948
  Submitted by:	Leo Vandewoestijne <freebsd@dns.company> (maintainer)
  Relnotes:	https://www.knot-resolver.cz/2020-01-27-knot-resolver-5.0.0.html
  		https://www.knot-resolver.cz/2020-02-05-knot-resolver-5.0.1.html

Changes:
  head/dns/knot-resolver/Makefile
  head/dns/knot-resolver/distinfo
  head/dns/knot-resolver/files/pkg-message.in
  head/dns/knot-resolver/pkg-plist