Bug 243950 - mail/rspamd fails to build under poudriere after update to 2.3
Summary: mail/rspamd fails to build under poudriere after update to 2.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Vsevolod Stakhov
URL:
Keywords: needs-qa
: 243951 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-07 00:36 UTC by lysfjord.daniel
Modified: 2020-02-09 19:29 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (vsevolod)
koobs: merge-quarterly?


Attachments
poudriere build log for rspamd-2.3 (743.03 KB, text/plain)
2020-02-07 00:36 UTC, lysfjord.daniel
no flags Details
patch for src/libutil/util.c (599 bytes, patch)
2020-02-07 13:47 UTC, lysfjord.daniel
no flags Details | Diff
path for config.h.in (379 bytes, patch)
2020-02-07 13:47 UTC, lysfjord.daniel
no flags Details | Diff
patch CMakeLists.txt (1.10 KB, patch)
2020-02-07 13:48 UTC, lysfjord.daniel
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description lysfjord.daniel 2020-02-07 00:36:38 UTC
Created attachment 211435 [details]
poudriere build log for rspamd-2.3

After update to 2.3, rspamd fails to build with poudriere.
Comment 1 lysfjord.daniel 2020-02-07 01:02:06 UTC

*** This bug has been marked as a duplicate of bug 243951 ***
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-07 03:35:32 UTC
^Triage: As a default newer bugs should be set as duplicates of the older issue ID's
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-07 03:35:39 UTC
*** Bug 243951 has been marked as a duplicate of this bug. ***
Comment 4 Vsevolod Stakhov freebsd_committer 2020-02-07 09:01:03 UTC
I cannot reproduce it.
Comment 5 lysfjord.daniel 2020-02-07 12:21:48 UTC
(In reply to Vsevolod Stakhov from comment #4)
My make.conf, if it would be of any help.

DEFAULT_VERSIONS+= mysql=10.4m
DEFAULT_VERSIONS+= ssl=libressl
DEFAULT_VERSIONS+= pgsql=11
OPTIONS_UNSET+= X11
OPTIONS_UNSET+= CUPS
OPTIONS_UNSET+= GNOME GTK1 GTK2 GTK3
OPTIONS_UNSET+= KDE4 QT4
OPTIONS_UNSET+= GSSAPI_BASE
OPTIONS_SET = GSSAPI_NONE
ftp_curl_UNSET= TLS_SRP
Comment 6 Vsevolod Stakhov freebsd_committer 2020-02-07 12:22:39 UTC
Ah, libressl... They have removed FIPS stuff. Too bad.
Comment 7 lysfjord.daniel 2020-02-07 12:38:32 UTC
So, I guess if I revert https://github.com/rspamd/rspamd/commit/1a90ff5e2731f4b10edc4b1725bd9aa7d1be5508#diff-83d355f2dd99b17093fcc5415c40871f

it'll work again. Maybe mark rspamd incompatible with libressl?
Comment 8 Vsevolod Stakhov freebsd_committer 2020-02-07 12:39:50 UTC
Yes, need to add some ifdef guards.
Comment 9 Vsevolod Stakhov freebsd_committer 2020-02-07 13:19:48 UTC
That should be fixed in https://github.com/rspamd/rspamd/commit/963657514d24c29604e0b873c17dcee0d3efd345
Comment 10 lysfjord.daniel 2020-02-07 13:45:39 UTC
(In reply to Vsevolod Stakhov from comment #9)

Applied the patches mentioned, and the package builds, installs and works perfectly. Thanks for the lightning quick handling of the issue.
Comment 11 lysfjord.daniel 2020-02-07 13:47:01 UTC
Created attachment 211443 [details]
patch for src/libutil/util.c

ifdef for handling missing FIPS mode on libressl
Comment 12 lysfjord.daniel 2020-02-07 13:47:44 UTC
Created attachment 211444 [details]
path for config.h.in

defined HAVE_FIPS_MODE for libressl
Comment 13 lysfjord.daniel 2020-02-07 13:48:51 UTC
Created attachment 211445 [details]
patch CMakeLists.txt

Check if crypto.h have the symbol FIPS_mode