Bug 243970 - print/lilypond-devel: Update to 2.20.0
Summary: print/lilypond-devel: Update to 2.20.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2020-02-08 02:24 UTC by m.ne
Modified: 2020-04-20 19:06 UTC (History)
2 users (show)

See Also:


Attachments
patch for print/lilypond-devel to 2.19.84 (7.29 KB, patch)
2020-02-08 02:24 UTC, m.ne
no flags Details | Diff
patch for print/lilypond-devel to 2.21.0 (17.31 KB, patch)
2020-04-19 15:24 UTC, m.ne
no flags Details | Diff
Patch for print/lilypond-devel to 2.20.0 (12.29 KB, patch)
2020-04-20 02:46 UTC, m.ne
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description m.ne 2020-02-08 02:24:13 UTC
Created attachment 211463 [details]
patch for print/lilypond-devel to 2.19.84

- Update to 2.19.84
- Recreate patches due to upstream changes
Comment 1 Automation User 2020-02-08 08:18:25 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/116051241
Comment 2 Adriaan de Groot freebsd_committer 2020-04-18 23:51:49 UTC
There is now a 2.20 available. We discussed this over email some time back -- if I remember right the idea was to bump both to the new release once Python2 can be dropped as a dependency.
Comment 3 m.ne 2020-04-19 15:24:16 UTC
Created attachment 213567 [details]
patch for print/lilypond-devel to 2.21.0
Comment 4 m.ne 2020-04-19 18:26:53 UTC
(In reply to Adriaan de Groot from comment #2)
It took a bit longer than expected to get my development computer hooked up to the internet again, creating a bit of a backlog I'm working to have cleared up right now. I've got updates (almost) ready for several other ports I'm maintaining that just need some functional testing. Lilypond 2.20 will then be next on my plate.
Comment 5 m.ne 2020-04-20 02:46:46 UTC
Created attachment 213590 [details]
Patch for print/lilypond-devel to 2.20.0

Updating only to 2.20.0 for now, as 2.21.0 does build but doesn't work properly.
Comment 6 Kurt Jaeger freebsd_committer 2020-04-20 19:05:57 UTC
Committed, thanks!
Comment 7 commit-hook freebsd_committer 2020-04-20 19:06:49 UTC
A commit references this bug:

Author: pi
Date: Mon Apr 20 19:05:48 UTC 2020
New revision: 532217
URL: https://svnweb.freebsd.org/changeset/ports/532217

Log:
  print/lilypond-devel: update 2.19.83 -> 2.20.0

  - back in sync with print/lilypond

  PR:		243970
  Submitted by:	Martin Neubauer <m.ne@gmx.net> (maintainer)
  Reviewed by:	adridg

Changes:
  head/print/lilypond-devel/Makefile
  head/print/lilypond-devel/distinfo
  head/print/lilypond-devel/files/patch-Documentation_GNUmakefile
  head/print/lilypond-devel/files/patch-config.make.in
  head/print/lilypond-devel/files/patch-configure
  head/print/lilypond-devel/files/patch-flower_include_std-string.hh
  head/print/lilypond-devel/files/patch-flower_include_std-vector.hh
  head/print/lilypond-devel/files/patch-lily_include_lily-guile.hh
  head/print/lilypond-devel/files/patch-python_GNUmakefile
  head/print/lilypond-devel/files/patch-stepmake_stepmake_texinfo-vars.make
  head/print/lilypond-devel/pkg-descr
  head/print/lilypond-devel/pkg-plist