Bug 244023 - www/otrs: Add missing misc/p5-Locale-Codes dependency
Summary: www/otrs: Add missing misc/p5-Locale-Codes dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2020-02-10 14:56 UTC by O. Hartmann
Modified: 2020-07-06 21:35 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback? (m.tsatsenko)
koobs: merge-quarterly?


Attachments
the patch (736 bytes, patch)
2020-07-06 21:30 UTC, m.tsatsenko
m.tsatsenko: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2020-02-10 14:56:17 UTC
www/otrs is missing port misc/p5-Locale-Codes. The problem is revealed in a German environment when trying to add a customer, resulting in some internal server failure. The problem completely disappear when installing manually port misc/p5-Locale-Codes.
Comment 1 m.tsatsenko 2020-02-10 23:25:51 UTC
Well. Thanks for reporting this. However do you have any positive evidence indicating misc/p5-Locale-Codes is being *directly* used by otrs? Did you check the sources for "use" statement? What is your check modules output?
Comment 2 Alexey Dokuchaev freebsd_committer 2020-07-04 09:57:47 UTC
(In reply to m.tsatsenko from comment #1)
> However do you have any positive evidence indicating misc/p5-Locale-Codes
> is being *directly* used by otrs?
$ grep -R 'use Locale' $wrkdir
otrs-rel-6_0_25/Kernel/System/ReferenceData.pm:use Locale::Country qw(all_country_names);
Comment 3 m.tsatsenko 2020-07-06 21:30:14 UTC
Created attachment 216266 [details]
the patch

- Add misc/p5-Locale-Codes dependency
- Bump PORTREVISION

QA:
poudrierre 121amd64 - OK
portlint - OK
Comment 4 commit-hook freebsd_committer 2020-07-06 21:34:50 UTC
A commit references this bug:

Author: demon
Date: Mon Jul  6 21:34:42 UTC 2020
New revision: 541365
URL: https://svnweb.freebsd.org/changeset/ports/541365

Log:
  Add missing p5-Locale-Codes dependency.

  PR:		244023
  Submitted by:	O. Hartmann <ohartmann@walstatt.org>
  Patch by:	m.tsatsenko@gmail.com (maintainer)

Changes:
  head/www/otrs/Makefile