Bug 244034 - www/chromium: Performance issues
Summary: www/chromium: Performance issues
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-chromium mailing list
URL:
Keywords: needs-qa, performance
Depends on:
Blocks:
 
Reported: 2020-02-11 02:59 UTC by Nicola Mingotti
Modified: 2020-02-24 08:24 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (chromium)


Attachments
dmesg (36.91 KB, text/plain)
2020-02-11 05:12 UTC, Nicola Mingotti
no flags Details
pkg-version (62.54 KB, text/plain)
2020-02-11 05:13 UTC, Nicola Mingotti
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicola Mingotti 2020-02-11 02:59:27 UTC
In FreeBSD-12.0-RELEASE, newly installed chromium via package:
chromium-79.0.3945.130
 
I observe several issues:

1] It blocks for several seconds in many pages.

2] Viewing youtube videos at times the audio goes on but the video part locks.

Points [1] and [2] appears to be similar to what is described here:
https://askubuntu.com/questions/1197898/chromium-freezes-intermittent-at-each-few-seconds

3] [FYI] At the beginning it was very slow, adding parameter "--use-gl=egl" performance is now better than pre-upgrade-state. 

4] [FYI] At the beginning the browser was crashing very frequently, I cancelld my cache and cookies, now It does not crash anymore. 

5] There are a lot of error messages like:
[86593:261771264:0210/134536.648412:ERROR:child_process_sandbox_support_impl_linux.cc(79)] FontService unique font name matching request did not receive a response.
=> adding parameter "--no-sandbox" was not helpful.

bye
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-11 03:07:05 UTC
How long have the issues been apparent? Is this a regression from the previous (79.0.3945.117) version or not? 

Also, please:

- Include the output of pkg version -v (as an attachment)
- Include the output of /var/run/dmesg.boot (as an attachment)
- Try the performance tip in the FreeBSD wiki and report back on any changes in behaviour / symptoms: https://wiki.freebsd.org/Ports/www/chromium
Comment 2 Nicola Mingotti 2020-02-11 05:12:50 UTC
Created attachment 211549 [details]
dmesg
Comment 3 Nicola Mingotti 2020-02-11 05:13:25 UTC
Created attachment 211550 [details]
pkg-version
Comment 4 Nicola Mingotti 2020-02-11 05:25:30 UTC
Hi, 

I attached the two files as asked.

Consider that I am running FreeBSD ina VMWare virtual machine in a MacBook Pro 2014. So, I am kind of used to have a slow browser. But usually it does not crash or hangs.

The issue stared one day ago when I upgraded the system and so also chrome.

I am not aware of the version of my previous chrome pagkage unfortunately.

Following the wiki i tried:
exec /usr/local/share/chromium/chrome ${1:+"$@"} --disable-gpu

Now it seems slower, it seems that YouTube audio-video-ansync is resolved but, the hanging problem remained. As I am typing this message (with no other browser window open) this window hanged once for a 5-6 seconds. 

I will tell you more in subsequent messages, I need some time to see how it behaves.
Comment 5 Nicola Mingotti 2020-02-11 17:11:25 UTC
Hi,

I did other tests, also on my network, my network is fine, the problem is in chromium.

It gets stuck, this either if I use the "--disable-gpu" parameter or don't.
It gets stuck on simple pages, like this one and complex one like GoogleDocuments. 

It "get's stuck" means that is freezes for a few seconds at its discretion. 

The only easy thing I still have not tried is to wipe out ~/.config/chromium.

I am writing this from Firefox.
Comment 6 yzrh 2020-02-13 10:44:24 UTC
Greetings,

I also have the same problem on some machines. It is likely GPU related.

I also discovered that if you do a right click, it will 'unfreeze' chromium.
Comment 7 Nicola Mingotti 2020-02-13 17:21:38 UTC
Hi,

I confirm @yzrh findings. Right click unlocks the browser. It also unlocks the stalled video stream in Youtube. 

I observe that the same procedure work if running as: 'chrome --no-gpu'.


bye
n.
Comment 8 Nicola Mingotti 2020-02-13 17:28:01 UTC
ERRATA-CORRIGE: 'chrome --disable-gpu'
Comment 9 yzrh 2020-02-14 11:33:30 UTC
The cause may be swiftshader. If I start chromium with --use-gl=egl, it does not seem to freeze.
Comment 10 Nicola Mingotti 2020-02-14 16:42:13 UTC
To me the option "--use-gl=egl" did not solve it. 

But, my main FreeBSD desktop machine is a guest in VMWare, that may complicate my case.
Comment 11 Felix Palmen 2020-02-18 10:54:48 UTC
On my machine with 8GB physical RAM and 8GB swap, I experience problems since the last upgrade from ports as well, but I didn't find the "smoking gun" yet to be sure it's because of chromium. What I observed so far is memory (and swap) usage continuously going up and the whole system stalling more and more frequently (probably because of I/O for swapping). As one of my chromium processes had a size of 11GB, and I couldn't reproduce this behavior so far without starting chromium (but I will do more tests to be sure), I assume it might be part of the issue.
Comment 12 Felix Palmen 2020-02-24 08:24:14 UTC
Please ignore the last comment, I found out it only happens when I start vice 3.4 at the same time, although vice looks unsuspicious in "top" output, the system starts eating swap -- so maybe it's related to vice, or to sndio, probably not to chromium itself :o