Bug 244065 - java/linux-oracle-jdk18: Only for amd64 i386, while you are running armv6
Summary: java/linux-oracle-jdk18: Only for amd64 i386, while you are running armv6
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Some People
Assignee: freebsd-java mailing list
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-02-12 03:55 UTC by 4593645
Modified: 2020-04-18 02:07 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (java)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 4593645 2020-02-12 03:55:37 UTC
linux-oracle-jdk18 arm bug

root@rpi-b:/usr/ports/java/linux-oracle-jdk18 # make install clean
===> linux-oracle-jdk18-8.241 is only for amd64 i386, while you are running
armv6.
*** Error code 1

Stop.
make: stopped in /usr/ports/java/linux-oracle-jdk18
root@rpi-b:/usr/ports/java/linux-oracle-jdk18 # brandelf -l
known ELF types are: FreeBSD(9) Linux(3) Solaris(6) SVR4(0)
root@rpi-b:/usr/ports/java/linux-oracle-jdk18 #
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-12 05:41:51 UTC
Not a bug. ONLY_FOR_ARCHS (the port is currently set to "i386 amd64") is intentional, but it may be the case that it could/should allow arm (and/or other architectures as well).
Comment 2 4593645 2020-02-12 06:43:08 UTC
yes,of course.
lizf@rpi-b:~ % uname -a
FreeBSD rpi-b 12.0-RELEASE FreeBSD 12.0-RELEASE r341666 RPI-B  arm
Comment 3 Mikael Urankar freebsd_committer 2020-02-13 07:38:40 UTC
(In reply to 4593645 from comment #0)
linux emulation is not available on armv6. We have openjdk8 for armv6 in ports, could you use that instead?
Comment 4 4593645 2020-02-13 09:17:29 UTC
(In reply to Mikael Urankar from comment #3)
We working service on oracle-jdk, cannot run on openjdk。
Comment 5 4593645 2020-02-15 15:59:26 UTC
(In reply to Kubilay Kocak from comment #1)
影响中国的学生!阿门!
Comment 6 4593645 2020-02-15 16:27:45 UTC
(In reply to Kubilay Kocak from comment #1)
【Mat20:27】and whosoever would be first among you shall be your servant:
Comment 7 Greg Lewis freebsd_committer 2020-04-18 02:07:50 UTC
This isn't a Java port bug.  It would require the Linux emulation to be made to work on armv6 for this to be possible.

Your choices at the moment are either to use the openjdk8 port or switch to a different platform, sorry.