Bug 244087 - x11/nvidia-driver: conflicts with graphics/egl-wayland
Summary: x11/nvidia-driver: conflicts with graphics/egl-wayland
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2020-02-13 04:16 UTC by Jan Beich
Modified: 2020-04-17 19:16 UTC (History)
0 users

See Also:


Attachments
v0 (1.74 KB, patch)
2020-02-13 04:28 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2020-02-13 04:16:19 UTC
Maybe nvidia-driver should stop installing Wayland bits.

$ make install -C graphics/egl-wayland
$ make install -C x11/nvidia-driver
[...]
Installing nvidia-driver-440.31...
pkg-static: nvidia-driver-440.31 conflicts with egl-wayland-1.1.4 (installs files into the same place).  Problematic file: /usr/local/lib/libnvidia-egl-wayland.so
*** Error code 70
Comment 1 Jan Beich freebsd_committer 2020-02-13 04:28:46 UTC
Created attachment 211603 [details]
v0
Comment 2 commit-hook freebsd_committer 2020-04-17 19:01:48 UTC
A commit references this bug:

Author: jbeich
Date: Fri Apr 17 19:01:25 UTC 2020
New revision: 531961
URL: https://svnweb.freebsd.org/changeset/ports/531961

Log:
  x11/nvidia-driver: stop installing files egl-wayland does

  PR:		244087
  Approved by:	maintainer timeout (2 months)

Changes:
  head/x11/nvidia-driver/Makefile
  head/x11/nvidia-driver/pkg-plist