Bug 244175 - www/cliqz: fix build on aarch64 (CURRENT)
Summary: www/cliqz: fix build on aarch64 (CURRENT)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Some People
Assignee: Santhosh Raju
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-02-16 20:48 UTC by Mikael Urankar
Modified: 2020-03-18 21:53 UTC (History)
1 user (show)

See Also:
fox: maintainer-feedback+
koobs: merge-quarterly?


Attachments
patch (1.97 KB, patch)
2020-02-16 20:48 UTC, Mikael Urankar
koobs: maintainer-approval+
Details | Diff
Fix checksum in distinfo (597 bytes, patch)
2020-02-17 11:22 UTC, Santhosh Raju
no flags Details | Diff
Fix checksum in distinfo (597 bytes, patch)
2020-02-17 11:23 UTC, Santhosh Raju
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikael Urankar freebsd_committer 2020-02-16 20:48:31 UTC
Created attachment 211699 [details]
patch

the interface has changed a bit on -current.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-17 02:39:29 UTC
Comment on attachment 211699 [details]
patch

Build fixes are:

Approved by: portmgr (blanket: build fix)
MFH: 2020Q1
Comment 2 Santhosh Raju freebsd_committer 2020-02-17 02:55:20 UTC
Was a poudriere build done for aarch64 and the other platforms (i386 / amd64) to make sure the patch works as intended?

Happy to commit the patch if has been tested out.
Comment 3 Mikael Urankar freebsd_committer 2020-02-17 09:00:12 UTC
(In reply to Santhosh Raju from comment #2)
Unfortunately the ports is currently broken:
===>   cliqz-1.32.1_1 depends on file: /usr/local/sbin/pkg - found
===>   cliqz-1.32.1_1 depends on package: ca_root_nss>=0 - found
===> Fetching all distfiles required by cliqz-1.32.1_1 for building
=> SHA256 Checksum mismatch for cliqz/adult-domains.bin.
=> SHA256 Checksum OK for cliqz/cliqz@cliqz.com.xpi.
=> SHA256 Checksum OK for cliqz/gdprtool@cliqz.com.xpi.
=> SHA256 Checksum OK for cliqz/https-everywhere@cliqz.com.xpi.
=> SHA256 Checksum OK for cliqz/cliqz-oss-browser-f-1.32.1_GH0.tar.gz.
===>  Giving up on fetching files:  cliqz/adult-domains.bin 
Make sure the Makefile and distinfo file (/usr/ports/www/cliqz/distinfo)
are up to date.  If you are absolutely sure you want to override this
check, type "make NO_CHECKSUM=yes [other args]".
Comment 4 Santhosh Raju freebsd_committer 2020-02-17 11:22:21 UTC
Created attachment 211715 [details]
Fix checksum in distinfo

Thank you for reporting that, I thought I had updated the checksum. 

I have attached a patch to update the checksum of the failing file.

Let me know if you are have trouble building cliqz after you apply that patch.
Comment 5 Santhosh Raju freebsd_committer 2020-02-17 11:23:57 UTC
Created attachment 211717 [details]
Fix checksum in distinfo

Thank you for reporting that, I thought I had updated the checksum. 

I have attached a patch to update the checksum of the failing file.

Let me know if you are have trouble building cliqz after you apply that patch.
Comment 6 Santhosh Raju freebsd_committer 2020-02-17 11:24:58 UTC
Comment on attachment 211717 [details]
Fix checksum in distinfo

>Index: distinfo
>===================================================================
>--- distinfo	(revision 526363)
>+++ distinfo	(working copy)
>@@ -1,5 +1,5 @@
>-TIMESTAMP = 1579729917
>-SHA256 (cliqz/adult-domains.bin) = fcbec6811ca696bd044c0cce7f7aae45f4b822797eb6ecf657e5dc795870418f
>+TIMESTAMP = 1581938094
>+SHA256 (cliqz/adult-domains.bin) = f726171965328f60e2cc2a50311883e76c21b3359f2596d10be76cc33abdda88
> SIZE (cliqz/adult-domains.bin) = 528392
> SHA256 (cliqz/cliqz@cliqz.com.xpi) = 8ff1fd47bbaa57f32356573f8f4b530e2c0219e5a1e87ba70cabad6d77b973a1
> SIZE (cliqz/cliqz@cliqz.com.xpi) = 3669619
Comment 7 Santhosh Raju freebsd_committer 2020-02-22 12:58:31 UTC
I have updated www/cliqz to 1.33.0, would you be able to test the aarch64 patch in that and make sure it builds correctly?

I do not have access to any aarch64 machines at the moment.
Comment 8 Mikael Urankar freebsd_committer 2020-03-18 15:06:47 UTC
(In reply to Santhosh Raju from comment #7)
Sorry for the late reply. It builds fine with the attached patch.
Comment 9 Santhosh Raju freebsd_committer 2020-03-18 15:24:23 UTC
Alright, I shall take your word for it, I shall apply this do a local build in my amd64 machine and commit.

Thank you for the patch.
Comment 10 commit-hook freebsd_committer 2020-03-18 21:49:36 UTC
A commit references this bug:

Author: fox
Date: Wed Mar 18 21:48:34 UTC 2020
New revision: 528672
URL: https://svnweb.freebsd.org/changeset/ports/528672

Log:
  www/cliqz: Fix build on aarch64 (CURRENT).

  PR:		244175
  Submitted by:	mikael@
  Reported by:	mikael@

Changes:
  head/www/cliqz/files/patch-mozilla-release_gfx_skia_skia_src_core_SkCpu.cpp
Comment 11 Santhosh Raju freebsd_committer 2020-03-18 21:53:40 UTC
(In reply to Mikael Urankar from comment #8)
Closing the ticket, since the patch has been committed. Thanks again.