Bug 244183 - www/phalcon: portscout fix and minor cleanup
Summary: www/phalcon: portscout fix and minor cleanup
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Lorenzo Salvadore
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2020-02-17 08:04 UTC by Franco Fichtner
Modified: 2020-03-10 22:09 UTC (History)
2 users (show)

See Also:


Attachments
portscout fix and minor cleanup (563 bytes, patch)
2020-02-17 08:04 UTC, Franco Fichtner
franco: maintainer-approval+
Details | Diff
second version with portlint fixes (757 bytes, patch)
2020-03-09 09:03 UTC, Franco Fichtner
franco: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Franco Fichtner 2020-02-17 08:04:17 UTC
Created attachment 211707 [details]
portscout fix and minor cleanup
Comment 1 Automation User 2020-02-17 08:32:02 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/118433112
Comment 2 Yuri Victorovich freebsd_committer 2020-02-17 19:35:33 UTC

*** This bug has been marked as a duplicate of bug 244184 ***
Comment 3 Franco Fichtner 2020-02-18 08:37:17 UTC
Separate port.
Comment 4 Lorenzo Salvadore freebsd_committer 2020-03-05 11:55:13 UTC
Franco, may I ask you to improve your cleanup? The variables order is not the standard one, please see https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/porting-order.html .

In particular,
- we normally put USE and USES_* toghether with their related variables in one unique block, i.e. without blank lines. So we would prefer if there was no blank line before USE_GITHUB;
- ONLY_FOR_ARCHS, CONFLICTS_INSTALL and PORTSCOUT should come after the USE block.

Once this is done and I have tested your patch I will commit it with my mentor (gerald@) approval.
Comment 5 Lorenzo Salvadore freebsd_committer 2020-03-05 17:35:18 UTC
(If you prefer to keep the blank line it is acceptable: it is not a big deal in this case.)
Comment 6 Franco Fichtner 2020-03-09 09:03:53 UTC
Created attachment 212280 [details]
second version with portlint fixes

Hi,

I'm not entirely sure on ONLY_FOR_ARCHS location as portlint insists on earlier mention.  I have attached a version that passes portlint, but can change it further if needed.  :)


Cheers,
Franco
Comment 7 commit-hook freebsd_committer 2020-03-10 22:04:21 UTC
A commit references this bug:

Author: salvadore
Date: Tue Mar 10 22:03:20 UTC 2020
New revision: 528199
URL: https://svnweb.freebsd.org/changeset/ports/528199

Log:
  www/phalcon: Portscout fix and minor cleanup

  PR:		244183
  Submitted by:	franco@opnsense.org (maintainer)
  Approved by:	gerald (mentor)

Changes:
  head/www/phalcon/Makefile
Comment 8 Lorenzo Salvadore freebsd_committer 2020-03-10 22:09:28 UTC
Committed, thanks!

You have put ONLY_FOR_ARCHS in the right place, please see https://www.freebsd.org/doc/en/books/porters-handbook/porting-order-broken.html .
Also, I moved back IGNORE_WITH_PHP to its original place for the reason you can read at the same link: this variable works only with USES= php, so it belongs to the USE block.

Thanks for maintaining this port!