Bug 244217 - lang/ghc fails in the configure phase while building using poudriere on 12-stable
Summary: lang/ghc fails in the configure phase while building using poudriere on 12-st...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-haskell mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-18 17:16 UTC by Robert Cina
Modified: 2020-02-20 06:24 UTC (History)
1 user (show)

See Also:
arrowd: maintainer-feedback+


Attachments
lang/ghc poudriere build log of the failure (78.60 KB, text/plain)
2020-02-18 17:16 UTC, Robert Cina
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cina 2020-02-18 17:16:06 UTC
Created attachment 211745 [details]
lang/ghc poudriere build log of the failure

The port lang/ghc fails to build for me at the configure stage on my 12-stable system. With the current ports tree: https://svn.freebsd.org/ports/head@526465. I have attached the poudriere build log if that helps.

Below is the error i receive:

x hscolour-1.24.4/Language/Haskell/HsColour/MIRC.hs
x hscolour-1.24.4/Language/Haskell/HsColour/Options.hs
x hscolour-1.24.4/Language/Haskell/HsColour/Output.hs
x hscolour-1.24.4/Language/Haskell/HsColour/TTY.hs
x hscolour-1.24.4/data/
x hscolour-1.24.4/data/rgb24-example-.hscolour
[1 of 1] Compiling Main             ( Setup.hs, Setup.o )
Linking Setup ...
Setup: No cabal file found.
Please create a package description file <pkgname>.cabal
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/ghc
=>> Cleaning up wrkdir
===>  Cleaning for ghc-8.6.5_3
build of lang/ghc | ghc-8.6.5_3 ended at Tue Feb 18 12:07:50 EST 2020
build time: 00:00:52
!!! build failure encountered !!!
Comment 1 Gleb Popov freebsd_committer 2020-02-18 18:02:16 UTC
What's output of

cat /usr/include/osreldate.h

on your system?
Comment 2 Robert Cina 2020-02-18 18:25:23 UTC
The output is as follows:

cat /usr/include/osreldate.h
/*-
 * SPDX-License-Identifier: BSD-2-Clause
 *
 * Copyright (c) 1992-2020 The FreeBSD Project.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 * 1. Redistributions of source code must retain the above copyright
 *    notice, this list of conditions and the following disclaimer.
 * 2. Redistributions in binary form must reproduce the above copyright
 *    notice, this list of conditions and the following disclaimer in the
 *    documentation and/or other materials provided with the distribution.
 *
 * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
 * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
 * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
 * ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
 * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
 * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
 * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
 * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
 * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
 * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
 * SUCH DAMAGE.
 *
 */

#ifdef _KERNEL
#error "<osreldate.h> cannot be used in the kernel, use <sys/param.h>"
#else
#undef __FreeBSD_version
#define __FreeBSD_version 1201512
#endif
Comment 3 commit-hook freebsd_committer 2020-02-19 18:30:51 UTC
A commit references this bug:

Author: arrowd
Date: Wed Feb 19 18:30:06 UTC 2020
New revision: 526523
URL: https://svnweb.freebsd.org/changeset/ports/526523

Log:
  lang/ghc: Now that we use different bootstraps, do not apply ino64 hack anymore.

  Unbreaks build on 12.1+

  PR:		244217

Changes:
  head/lang/ghc/Makefile
  head/lang/ghc/distinfo
Comment 4 Gleb Popov freebsd_committer 2020-02-19 18:37:08 UTC
Works for me now. Please confirm that it works for you too.
Comment 5 Robert Cina 2020-02-19 19:52:59 UTC
I can confirm it build and works now. Thanks.
Comment 6 Gleb Popov freebsd_committer 2020-02-20 06:24:08 UTC
deal_with_it.jpg

Thanks for the report!