Bug 244221 - ports-mgmt/pkg: Fails to build/run: Lzma library error: No progress is possible / Failed assertion: "nstime_compare(&decay->epoch, &time) <= 0 on 13.0-CURRENT-r357606
Summary: ports-mgmt/pkg: Fails to build/run: Lzma library error: No progress is possib...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-pkg (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-02-19 02:09 UTC by Haocheng Zhang
Modified: 2020-03-30 02:12 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (pkg)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Haocheng Zhang 2020-02-19 02:09:18 UTC
I am using Freebsd 13.0-CURRENT(the reason I used this version is: 1. I'm not an engineer, just to familiarize myself with linux and cli; 2. I thought this issue is a problem of 12.x and might be solved in 13.x!), and I can't use the pkg tool. When I bootstrap it, it gives error "Failed to extract /usr/local/share/zsh/site-functions/_pkg from package: Lzma library error: No progress is possible". When I build ports-mgmt/pkg, it also gives error: "<jemalloc>: jemalloc_arena.c:647: Failed assertion: "nstime_compare(&decay->epoch, &time) <= 0".I REALLY want to use it, but I don't have any solutions.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-19 03:07:29 UTC
@Haocheng Could you please provide:

- Exact FreeBSD version (uname -a)
- Two complete logs of commands ran, and all output from those comments, one for each of failing to build ports-mgmt/pkg and the failure case for running pkg
- Confirmation that the ports tree used to build pkg is up to date (portsnap fetch update, or svn update)
Comment 2 Haocheng Zhang 2020-02-19 05:31:15 UTC
Output of uname -a: 
http://mpuw-um9c5.byethost4.com/unamea.txt

Output of make install clean in ports-mgmt/pkg: 
http://mpuw-um9c5.byethost4.com/pkgmake.log

Output of make install clean in editor/dte (one of the package I want to have):
http://mpuw-um9c5.byethost4.com/dtemake.log

Note: Log files are generated by 'make install clean' > [package-name]make.log
Comment 3 Haocheng Zhang 2020-02-19 05:58:38 UTC
UPDATE:
Output when running make install clean in ports-mgmt/dislog4ports:
http://mpuw-um9c5.byethost4.com/d4pmake.log
Note: I see one line of output not in the log files listed above: "No installed jimsh or tclsh, building bootstrap jimsh0". Probably it's wrote to stderr not stdout as `>' expected?
Comment 4 Haocheng Zhang 2020-02-19 06:00:38 UTC
(In reply to Haocheng Zhang from comment #3)
The note means that that line of output is not written into the file, instead written to console.
Comment 5 Haocheng Zhang 2020-02-20 03:15:50 UTC
Sorry I didn't give the log bootstraping pkg. Here it is:
http://mpuw-um9c5.byethost4.com/pkgboot.log
Comment 6 Haocheng Zhang 2020-02-25 04:27:52 UTC
UPDATE2 (2020.02.25 12:22:46 CST): Reinstalled system, I still can't use it. What's more, when I tried to download (using ftp) the source of autoconf and its dependency m4 from ftp://ftp.gnu.org, it can download successfully, but then when extracting the .tar.xz archive, it gives same error as the summary: Lzma library error: No progress is possible.
Comment 7 Haocheng Zhang 2020-03-03 01:41:38 UTC
UPDATE3: 2020/03/03 09:42:03 CST
Now downloading m4 doesn't have any problem, but building it has. Gives error as described here: https://unix.stackexchange.com/questions/570646/building-m4-from-source-on-freebsd-error-dont-know-how-to-make-build-aux
Comment 8 Haocheng Zhang 2020-03-30 02:12:16 UTC
Magically solved by downgrading to 12.0. Maybe it's a bug with 13.0.