Bug 244224 - devel/py-oci: Update to 2.10.5
Summary: devel/py-oci: Update to 2.10.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Koichiro Iwao
URL: https://github.com/oracle/oci-python-...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-19 05:44 UTC by Alessandro Sagratini
Modified: 2020-03-04 09:45 UTC (History)
1 user (show)

See Also:


Attachments
py-oci update to 2.10.5 version (1.05 KB, patch)
2020-02-19 05:44 UTC, Alessandro Sagratini
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Sagratini 2020-02-19 05:44:13 UTC
Created attachment 211755 [details]
py-oci update to 2.10.5 version

py-oci update to 2.10.5 version
Comment 1 Koichiro Iwao freebsd_committer 2020-02-19 06:40:57 UTC
Thank you always!

BTW, is it possible to create a port for oci-cli?
Comment 2 Koichiro Iwao freebsd_committer 2020-02-19 06:42:55 UTC
Strangely, the distfile is just 1 byte short.

===>  License APACHE20 UPL accepted by the user
===>   py37-oci-2.10.5 depends on file: /usr/local/sbin/pkg - found
=> oci-2.10.5.tar.gz doesn't seem to exist in /portdistfiles/.
=> Attempting to fetch https://files.pythonhosted.org/packages/source/o/oci/oci-2.10.5.tar.gz
fetch: https://files.pythonhosted.org/packages/source/o/oci/oci-2.10.5.tar.gz: size mismatch: expected 196213, actual 1962132
Comment 3 Alessandro Sagratini 2020-02-19 13:26:02 UTC
mmmh, that is weird Koichiro, what commands did you run to get that error message?

I tried following ones, but it looks fine:
[ale@router ~]$ fetch https://files.pythonhosted.org/packages/source/o/oci/oci-2.10.5.tar.gz
oci-2.10.5.tar.gz                                     1916 kB 6880 kBps    00s
[ale@router ~]$ ls -l oci-2.10.5.tar.gz
-rw-r--r--  1 ale  ale  1962132 Feb 18 17:58 oci-2.10.5.tar.gz
[ale@router ~]$ sha256 oci-2.10.5.tar.gz
SHA256 (oci-2.10.5.tar.gz) = 05bde3f5390ceef7b256eed01a899ab38f0845a92c5348388408a7df3c641f27
Comment 4 Alessandro Sagratini 2020-02-19 13:29:28 UTC
with regards to the OCI cli question, yes, I am thinking about it, but I have a question: I noticed in setup.py file [1] that package depends on specific python libraries, for example oci-sdk version 2.10.5, configparser 3.5.0 or six 1.11.0.

What is the official FreeBSD policy with regards to such python packages? What about installing something in a virtualenv?

Thank you

[1] https://github.com/oracle/oci-cli/blob/master/setup.py
Comment 5 Koichiro Iwao freebsd_committer 2020-02-21 02:51:05 UTC
(In reply to Alessandro Sagratini from comment #3)
I tested it by poudriere but `make distclean stage` also reproduces the error.
Maybe it's ok to regenerate distinfo. I guess the tarball has been replaced silently.
Comment 6 commit-hook freebsd_committer 2020-02-21 03:02:55 UTC
A commit references this bug:

Author: meta
Date: Fri Feb 21 03:02:21 UTC 2020
New revision: 526603
URL: https://svnweb.freebsd.org/changeset/ports/526603

Log:
  deve/py-oci: Update to 2.10.5

  - Support for the NoSQL Database service
  - Support for filtering database versions by storage management type in the
    Database service
  - Support for specifying paid listing types within pricing models in the
    Marketplace service
  - Support for primary and non-primary instance types in the Content and
    Experience service

  PR:		244224
  Submitted by:	Alessandro Sagratini <ale_sagra@hotmail.com> (maintainer)
  Relnotes:	https://github.com/oracle/oci-python-sdk/releases/tag/v2.10.5

Changes:
  head/devel/py-oci/Makefile
  head/devel/py-oci/distinfo
Comment 7 Koichiro Iwao freebsd_committer 2020-02-21 03:12:39 UTC
(In reply to Alessandro Sagratini from comment #4)
Regarding oci-cli, I personally using virtualenv to install oci-cli. I suggest creating oci-cli port if it's easy but actually it sounds not easy, I stay on virtualenv.

I am a Ruby folk rather than Python but generally, requisite packages such as configparser 3.5.0 or six 1.11.0 should be created if oci-cli depends on them and doesn't exist in the ports tree. However, that will be too much hassle.
Comment 8 Alessandro Sagratini 2020-02-25 10:21:05 UTC
Thanks Koichiro, in the meantime, I kept in touch in freebsd-ports mailing list and got following response:
https://lists.freebsd.org/pipermail/freebsd-ports/2020-February/117766.html

to recap, it seems to be too much of a work to keep the port up-to-date (in terms of testing), qa, etc): my understanding is to keep using oci-cli in a virtualenv, at the moment, as you correctly pointed out
Comment 9 Alessandro Sagratini 2020-03-04 09:35:07 UTC
since there is no further action on this bug, I am going to resolve it, let me know if you need anything else on this
Comment 10 Koichiro Iwao freebsd_committer 2020-03-04 09:45:15 UTC
(In reply to Alessandro Sagratini from comment #9)

Everything's done in this bug, thanks! Regarding oci-cli, stay on virtualenv.