Bug 244231 - editors/emacs 26.3_3,3 segfaults after (or during) loading "image"
Summary: editors/emacs 26.3_3,3 segfaults after (or during) loading "image"
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: emacs@FreeBSD.org (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-19 17:26 UTC by rkoberman
Modified: 2020-07-20 18:42 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (emacs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rkoberman 2020-02-19 17:26:52 UTC
26.3_3,3 segfaults during the build while loading modules:
Loading textmodes/text-mode...
Loading textmodes/fill...
Loading newcomment...
Loading replace...
Loading emacs-lisp/tabulated-list...
Loading buff-menu...
Loading fringe...
Loading emacs-lisp/regexp-opt...
Loading image...
gmake[3]: *** [Makefile:741: bootstrap-emacs] Segmentation fault (core dumped)
gmake[3]: Leaving directory '/usr/ports/editors/emacs/work-full/emacs-26.3/src'
gmake[2]: *** [Makefile:421: src] Error 2
gmake[2]: Leaving directory '/usr/ports/editors/emacs/work-full/emacs-26.3'

Running 12-STABLE r356573M on amd64 system.
Comment 1 Joseph Mingrone freebsd_committer 2020-02-19 17:42:31 UTC
Thanks for reporting.  I cannot reproduce this in a 12.0 poudriere jail [1], so I wonder if it is due to a change introduced in 12-STABLE.  This seems plausible, because the only change in the recent PORTREVISION bump of editors/emacs was the introduction of a non-default option.

I'll try updating the jail to 12.1 (since the default packages will soon switch to 12.1 as well) to see if this triggers the problem.  In the meantime, if you could try to dig deeper to discover the problem that would be helpful.  If you need to get back to work, editors/emacs-devel is in good shape and might work for you.

[1] http://pkg.awarnach.mathstat.dal.ca/data/12amd64-default/2020-02-19_13h30m13s/logs/emacs-26.3_3,3.log
Comment 2 rkoberman 2020-02-20 02:08:34 UTC
Just downgraded to emacs-devel-26.0.50.20200214,2 ("Dongraded" is the message I got) with no problems. I did need to reset my default font, but everything I've tried has been fine.

I can try some troubleshooting when I have time, but it's been years since I wrote a line of elisp and have not looked at the build process even longer. So I think I'll need a hint or three. I assume that the section of the process where .el files are loaded, but I am not sure of anything.
Comment 3 Joseph Mingrone freebsd_committer 2020-02-20 02:39:32 UTC
That should be emacs-devel-28.0.50.20200214,2 (note the 28) right?  I don't have any guesses about what is being downgraded or where the spelling error is coming from.  I grepped the `pkg` source and the ports tree for 'Dongrad' but didn't get any hits.

If you do find time and motivation, probably the best way to discover the source of the problem would be to turn on debugging for the build, then get a stack track from the core dump.  So, no need for any elisp.
Comment 4 rkoberman 2020-02-20 03:32:06 UTC
Just switched to emacs-devel-26.0.50.20200214,2 with no problems. I did need to reset my default font, but everything I have tried has been fine.

I can try some troubleshooting when I have time, but it's been years since I wrote a line of elisp and have not looked at the build process even longer. So I think I'll need a hint or three. I assume that the section of the build where .el files are loaded is where it is failing, but I am not sure of anything.
Comment 5 rkoberman 2020-02-21 05:40:25 UTC
Sorry, I can't read. It is 28. I have no idea how portmaster decided it was a downgrade, but it's not significant.
Comment 6 rkoberman 2020-07-20 18:42:18 UTC
This is no longer an issue with the current version.