Bug 244260 - dns/bind916 startup failed @ parser.c.
Summary: dns/bind916 startup failed @ parser.c.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Mathieu Arnold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-21 05:15 UTC by epopen
Modified: 2020-06-18 10:10 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (mat)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description epopen 2020-02-21 05:15:14 UTC
Hi Maintainer.

First, thanks your hard work :D
Base your work, I tried to upgrade BIND to 9.16.
But could not start and got error as below.

Feb 21 11:36:30 dns named[24818]: starting BIND 9.16.0 (Stable Release) <id:6270e60>
Feb 21 11:36:30 dns named[24818]: running on FreeBSD amd64 12.1-RELEASE-p1 FreeBSD 12.1-RELEASE-p1 #7 r335865M: Sat Nov 16 09:04:56 CST 2019     root@epopen.com:/usr/obj/usr/src/amd64.amd64/sys/EpopenKernel
Feb 21 11:36:30 dns named[24818]: built with '--disable-linux-caps' '--localstatedir=/var' '--sysconfdir=/usr/local/etc/namedb' '--with-dlopen=yes' '--with-libxml2' '--with-openssl=/usr/local' '--with-readline=-L/usr/local/lib -ledit' '--with-dlz-filesystem=yes' '--enable-dnstap' '--disable-fixed-rrset' '--disable-geoip' '--without-maxminddb' '--without-gssapi' '--with-libidn2=/usr/local' '--with-json-c' '--disable-largefile' '--with-lmdb=/usr/local' '--disable-native-pkcs11' '--without-python' '--disable-querytrace' 'STD_CDEFINES=-DDIG_SIGCHASE=1' '--enable-tcp-fastopen' '--with-tuning=default' '--disable-symtable' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/share/info/' '--build=amd64-portbld-freebsd12.1' 'build_alias=amd64-portbld-freebsd12.1' 'CC=cc' 'CFLAGS=-O2 -pipe -march=core2 -DLIBICONV_PLUG -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing ' 'LDFLAGS= -L/usr/local/lib -ljson-c -Wl,-rpath,/usr/local/lib -fstack-protector-strong ' 'LIBS=-L/usr/local/lib' 'CPPFLAGS=-DLIBICONV_PLUG -isystem /usr/local/include' 'CPP=cpp' 'PKG_CONFIG=pkgconf'
Feb 21 11:36:30 dns named[24818]: running as: named -u bind -c /usr/local/etc/namedb/named.conf
Feb 21 11:36:30 dns named[24818]: compiled by CLANG 4.2.1 Compatible FreeBSD Clang 8.0.1 (tags/RELEASE_801/final 366581)
Feb 21 11:36:30 dns named[24818]: compiled with OpenSSL version: OpenSSL 1.1.1d  10 Sep 2019
Feb 21 11:36:30 dns named[24818]: linked to OpenSSL version: OpenSSL 1.1.1d  10 Sep 2019
Feb 21 11:36:30 dns named[24818]: compiled with libxml2 version: 2.9.10
Feb 21 11:36:30 dns named[24818]: linked to libxml2 version: 20910
Feb 21 11:36:30 dns named[24818]: compiled with json-c version: 0.13.1
Feb 21 11:36:30 dns named[24818]: linked to json-c version: 0.13.1
Feb 21 11:36:30 dns named[24818]: compiled with zlib version: 1.2.11
Feb 21 11:36:30 dns named[24818]: linked to zlib version: 1.2.11
Feb 21 11:36:30 dns named[24818]: ----------------------------------------------------
Feb 21 11:36:30 dns named[24818]: BIND 9 is maintained by Internet Systems Consortium,
Feb 21 11:36:30 dns named[24818]: Inc. (ISC), a non-profit 501(c)(3) public-benefit
Feb 21 11:36:30 dns named[24818]: corporation.  Support and training for BIND 9 are
Feb 21 11:36:30 dns named[24818]: available at https://www.isc.org/support
Feb 21 11:36:30 dns named[24818]: ----------------------------------------------------
Feb 21 11:36:30 dns named[24818]: found 2 CPUs, using 2 worker threads
Feb 21 11:36:30 dns named[24818]: using 2 UDP listeners per interface
Feb 21 11:36:30 dns named[24818]: using up to 21000 sockets
Feb 21 11:36:30 dns named[24818]: loading configuration from '/usr/local/etc/namedb/named.conf'
Feb 21 11:36:30 dns named[24818]: reading built-in trust anchors from file '/usr/local/etc/namedb/bind.keys'
Feb 21 11:36:30 dns named[24818]: using default UDP/IPv4 port range: [49152, 65535]
Feb 21 11:36:30 dns named[24818]: using default UDP/IPv6 port range: [49152, 65535]
Feb 21 11:36:30 dns named[24818]: listening on IPv4 interface lo1, 10.0.0.1#53
Feb 21 11:36:30 dns named[24818]: IPv6 socket API is incomplete; explicitly binding to each IPv6 address separately
Feb 21 11:36:30 dns named[24818]: listening on IPv6 interface lo1, fd00::ffff:a00:1#53
Feb 21 11:36:30 dns named[24818]: generating session key for dynamic DNS
Feb 21 11:36:30 dns named[24818]: sizing zone task pool based on 158 zones
Feb 21 11:36:30 dns named[24818]: none:100: 'max-cache-size 90%' - setting to 3519MB (out of 3910MB)
Feb 21 11:36:30 dns named[24818]: parser.c:978: REQUIRE(obj != ((void *)0) && obj->type->rep == &cfg_rep_uint32) failed, back trace
Feb 21 11:36:30 dns named[24818]: #0 0x2cec90 in ??
Feb 21 11:36:30 dns named[24818]: #1 0x4ae25a in ??
Feb 21 11:36:30 dns named[24818]: #2 0x4a2047 in ??
Feb 21 11:36:30 dns named[24818]: #3 0x2e369f in ??
Feb 21 11:36:30 dns named[24818]: #4 0x2df393 in ??
Feb 21 11:36:30 dns named[24818]: #5 0x2d04c9 in ??
Feb 21 11:36:30 dns named[24818]: #6 0x4d3362 in ??
Feb 21 11:36:30 dns named[24818]: #7 0x800a4d735 in ??
Feb 21 11:36:30 dns named[24818]: exiting (due to assertion failure)

About configue file named.conf.
Used /usr/local/etc/namedb/named.conf.sample and got same failed.

Can help me debug it?
Thanks a lot.
Comment 1 doctor 2020-02-21 14:07:04 UTC
The issue is with bind 9.16.0 itself

A proposed solution is found in https://lists.isc.org/pipermail/bind-users/2020-February/102660.html
Comment 2 epopen 2020-02-24 02:28:20 UTC
(In reply to doctor from comment #1)
Thanks your reply quickly.
I will confirm next release and close the bug.
Comment 3 Mathieu Arnold freebsd_committer 2020-03-19 15:29:10 UTC
updated to 9.16.1.
Comment 4 epopen 2020-03-21 15:55:39 UTC
(In reply to Mathieu Arnold from comment #3)

Hi All.
I updated to 9.16.1 via ports and tried again but got same error as below..

Mar 21 23:40:43 dns named[45456]: starting BIND 9.16.1 (Stable Release) <id:d497c32>
Mar 21 23:40:43 dns named[45456]: running on FreeBSD amd64 12.1-RELEASE-p3 FreeBSD 12.1-RELEASE-p3 #8 r335865M: Fri Mar 20 19:53:12 CST 2020     root@epopen.com:/usr/obj/usr/src/amd64.amd64
/sys/EpopenKernel
Mar 21 23:40:43 dns named[45456]: built with '--disable-linux-caps' '--localstatedir=/var' '--sysconfdir=/usr/local/etc/namedb' '--with-dlopen=yes' '--with-libxml2' '--with-openssl=/usr/loc
al' '--with-readline=-L/usr/local/lib -ledit' '--with-dlz-filesystem=yes' '--enable-dnstap' '--disable-fixed-rrset' '--disable-geoip' '--without-maxminddb' '--without-gssapi' '--with-libidn
2=/usr/local' '--with-json-c' '--disable-largefile' '--with-lmdb=/usr/local' '--disable-native-pkcs11' '--without-python' '--disable-querytrace' 'STD_CDEFINES=-DDIG_SIGCHASE=1' '--enable-tc
p-fastopen' '--with-tuning=default' '--disable-symtable' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/share/info/' '--build=amd64-portbld-freebsd12.1' 'build_alias=
amd64-portbld-freebsd12.1' 'CC=cc' 'CFLAGS=-O2 -pipe -march=core2 -DLIBICONV_PLUG -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing ' 'LDFLAGS= -L/usr/local/lib -ljs
on-c -Wl,-rpath,/usr/local/lib -fstack-protector-strong ' 'LIBS=-L/usr/local/lib' 'CPPFLAGS=-DLIBICONV_PLUG -isystem /usr/local/include' 'CPP=cpp' 'PKG_CONFIG=pkgconf'
Mar 21 23:40:43 dns named[45456]: running as: named -u bind -c /usr/local/etc/namedb/named.conf
Mar 21 23:40:43 dns named[45456]: compiled by CLANG 4.2.1 Compatible FreeBSD Clang 8.0.1 (tags/RELEASE_801/final 366581)
Mar 21 23:40:43 dns named[45456]: compiled with OpenSSL version: OpenSSL 1.1.1e  17 Mar 2020
Mar 21 23:40:43 dns named[45456]: linked to OpenSSL version: OpenSSL 1.1.1e  17 Mar 2020
Mar 21 23:40:43 dns named[45456]: compiled with libxml2 version: 2.9.10
Mar 21 23:40:43 dns named[45456]: linked to libxml2 version: 20910
Mar 21 23:40:43 dns named[45456]: compiled with json-c version: 0.13.1
Mar 21 23:40:43 dns named[45456]: linked to json-c version: 0.13.1
Mar 21 23:40:43 dns named[45456]: compiled with zlib version: 1.2.11
Mar 21 23:40:43 dns named[45456]: linked to zlib version: 1.2.11
Mar 21 23:40:43 dns named[45456]: ----------------------------------------------------
Mar 21 23:40:43 dns named[45456]: BIND 9 is maintained by Internet Systems Consortium,
Mar 21 23:40:43 dns named[45456]: Inc. (ISC), a non-profit 501(c)(3) public-benefit
Mar 21 23:40:43 dns named[45456]: corporation.  Support and training for BIND 9 are
Mar 21 23:40:43 dns named[45456]: available at https://www.isc.org/support
Mar 21 23:40:43 dns named[45456]: ----------------------------------------------------
Mar 21 23:40:43 dns named[45456]: found 2 CPUs, using 2 worker threads
Mar 21 23:40:43 dns named[45456]: using 2 UDP listeners per interface
Mar 21 23:40:43 dns named[45456]: using up to 21000 sockets
Mar 21 23:40:43 dns named[45456]: loading configuration from '/usr/local/etc/namedb/named.conf'
Mar 21 23:40:43 dns named[45456]: reading built-in trust anchors from file '/usr/local/etc/namedb/bind.keys'
Mar 21 23:40:43 dns named[45456]: using default UDP/IPv4 port range: [49152, 65535]
Mar 21 23:40:43 dns named[45456]: using default UDP/IPv6 port range: [49152, 65535]
Mar 21 23:40:43 dns named[45456]: IPv6 socket API is incomplete; explicitly binding to each IPv6 address separately
Mar 21 23:40:43 dns named[45456]: listening on IPv6 interface lo0, ::1#53
Mar 21 23:40:43 dns named[45456]: listening on IPv6 interface lo0, fe80::1%1#53
Mar 21 23:40:43 dns named[45456]: listening on IPv4 interface lo0, 127.0.0.1#53
Mar 21 23:40:43 dns named[45456]: listening on IPv4 interface ng0_named, 10.0.2.1#53
Mar 21 23:40:43 dns named[45456]: listening on IPv6 interface ng0_named, fe80::8c0:c4ff:fec4:e19e%4#53
Mar 21 23:40:43 dns named[45456]: listening on IPv6 interface ng0_named, fd00::ffff:a00:201#53
Mar 21 23:40:43 dns named[45456]: generating session key for dynamic DNS
Mar 21 23:40:43 dns named[45456]: sizing zone task pool based on 158 zones
Mar 21 23:40:43 dns named[45456]: none:100: 'max-cache-size 90%' - setting to 3519MB (out of 3910MB)
Mar 21 23:40:43 dns named[45456]: parser.c:950: REQUIRE(obj != ((void *)0) && obj->type->rep == &cfg_rep_uint32) failed, back trace
Mar 21 23:40:43 dns named[45456]: #0 0x2cec90 in ??
Mar 21 23:40:43 dns named[45456]: #1 0x4ae8aa in ??
Mar 21 23:40:43 dns named[45456]: #2 0x4a2697 in ??
Mar 21 23:40:43 dns named[45456]: #3 0x2e369f in ??
Mar 21 23:40:43 dns named[45456]: #4 0x2df393 in ??
Mar 21 23:40:43 dns named[45456]: #5 0x2d04d1 in ??
Mar 21 23:40:43 dns named[45456]: #6 0x4d33bb in ??
Mar 21 23:40:43 dns named[45456]: #7 0x800a52735 in ??
Mar 21 23:40:43 dns named[45456]: exiting (due to assertion failure)

My base system issue exist look like.
Can provide debug suggestion to me?

Thanks all very much.
Comment 5 epopen 2020-05-20 03:28:58 UTC
Hi Maintainer.

I updated to 9.16.3 via ports and tried again but got same error as below..

May 20 11:24:15 dns named[58957]: starting BIND 9.16.3 (Stable Release) <id:5ea41c1>
May 20 11:24:15 dns named[58957]: running on FreeBSD amd64 12.1-RELEASE-p3 FreeBSD 12.1-RELEASE-p3 #9 r335865M: Thu Apr 16 13:18:03 CST 2020     root@epopen.com:/usr/obj/usr/src/amd64.amd64/sys/EpopenKern
el
May 20 11:24:15 dns named[58957]: built with '--disable-linux-caps' '--localstatedir=/var' '--sysconfdir=/usr/local/etc/namedb' '--with-dlopen=yes' '--with-libxml2' '--with-openssl=/usr/local' '--with-rea
dline=-L/usr/local/lib -ledit' '--with-dlz-filesystem=yes' '--enable-dnstap' '--disable-fixed-rrset' '--disable-geoip' '--without-maxminddb' '--with-gssapi=/usr/local' 'CFLAGS=-I/usr/local/include/heimdal
 -O2 -pipe -march=core2 -DLIBICONV_PLUG -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing ' 'LDFLAGS=-L/usr/local/lib/heimdal -Wl,-rpath,/usr/local/lib/heimdal:/usr/local/lib -L/us
r/local/lib -ljson-c -fstack-protector-strong ' 'LIBS=-lkrb5 -lgssapi -L/usr/local/lib' 'KRB5CONFIG=/usr/local/bin/krb5-config' '--with-libidn2=/usr/local' '--with-json-c' '--enable-largefile' '--with-lmd
b=/usr/local' '--disable-native-pkcs11' '--without-python' '--disable-querytrace' 'STD_CDEFINES=-DDIG_SIGCHASE=1' '--enable-tcp-fastopen' '--with-tuning=default' '--disable-symtable' '--prefix=/usr/local'
 '--mandir=/usr/local/man' '--infodir=/usr/local/share/info/' '--build=amd64-portbld-freebsd12.1' 'build_alias=amd64-portbld-freebsd
12.1' 'CC=cc' 'CPPFLAGS=-DLIBICONV_PLUG -isystem /usr/local/include' 'CPP=cpp' 'PKG_CONFIG=pkgconf'
......
May 20 11:24:15 dns named[58957]: parser.c:950: REQUIRE(obj != ((void *)0) && obj->type->rep == &cfg_rep_uint32) failed, back trace
May 20 11:24:15 dns named[58957]: #0 0x2cfd10 in ??
May 20 11:24:15 dns named[58957]: #1 0x4b7cba in ??
May 20 11:24:15 dns named[58957]: #2 0x4aba77 in ??
May 20 11:24:15 dns named[58957]: #3 0x2e465f in ??
May 20 11:24:15 dns named[58957]: #4 0x2e041c in ??
May 20 11:24:15 dns named[58957]: #5 0x2d1551 in ??
May 20 11:24:15 dns named[58957]: #6 0x4dd56b in ??
May 20 11:24:15 dns named[58957]: #7 0x8007fc735 in ??
May 20 11:24:15 dns named[58957]: exiting (due to assertion failure)

So I reopen the issue, sorry if mistake.
Thanks a lot.
Comment 6 epopen 2020-05-27 10:05:03 UTC
Hi Maintainer.

I tried to build with WITH_DEBUG and got error with symbol as below..
May 26 00:22:28 dns named[11747]: none:100: 'max-cache-size 90%' - setting to 3521MB (out of 3912MB)
May 26 00:22:28 dns named[11747]: parser.c:950: REQUIRE(obj != ((void *)0) && obj->type->rep == &cfg_rep_uint32) failed, back trace
May 26 00:22:28 dns named[11747]: #0 0x2ff759 in assertion_failed()+0x59
May 26 00:22:28 dns named[11747]: #1 0x67d428 in isc_assertion_failed()+0x38
May 26 00:22:28 dns named[11747]: #2 0x66adc9 in cfg_obj_asuint32()+0x69
May 26 00:22:28 dns named[11747]: #3 0x32004c in configure_view()+0x19ac
May 26 00:22:28 dns named[11747]: #4 0x319230 in load_configuration()+0x2c20
May 26 00:22:28 dns named[11747]: #5 0x3042d5 in run_server()+0x485
May 26 00:22:28 dns named[11747]: #6 0x6c7489 in dispatch()+0xc79
May 26 00:22:28 dns named[11747]: #7 0x6c2f21 in run()+0x41
May 26 00:22:28 dns named[11747]: #8 0x8009f1735 in _fini()+0x80030bd59
May 26 00:22:28 dns named[11747]: exiting (due to assertion failure)

Look like configure option issue.
Next, I shrank configure file (/usr/local/etc/namedb/named.conf) as below, and got same error.
    options {
       directory   "/usr/local/etc/namedb/working";
       pid-file    "/var/run/named/pid";
    }; 

Next, comment out source code (line 4597~4618 @ bin/named/server.c, base: bind916-9.16.3_2) as below
    /*                                                                              obj = NULL;
    result = named_config_get(maps, "fetches-per-server", &obj);
    INSIST(result == ISC_R_SUCCESS);
    obj2 = cfg_tuple_get(obj, "fetches");
    fps = cfg_obj_asuint32(obj2);
    obj2 = cfg_tuple_get(obj, "response");
    if (!cfg_obj_isvoid(obj2)) {
        const char *resp = cfg_obj_asstring(obj2);
        isc_result_t r = DNS_R_SERVFAIL;

        if (strcasecmp(resp, "drop") == 0) {
            r = DNS_R_DROP;
        } else if (strcasecmp(resp, "fail") == 0) {
            r = DNS_R_SERVFAIL;
        } else {
            INSIST(0);
            ISC_UNREACHABLE();
        }

        dns_resolver_setquotaresponse(view->resolver,
                          dns_quotatype_server, r);
    }
   */

Bind start successful and work fine as below.
May 26 18:08:34 dns named[87177]: starting BIND 9.16.3 (Stable Release) <id:5ea41c1>
May 26 18:08:34 dns named[87177]: running on FreeBSD amd64 12.1-RELEASE-p3 FreeBSD 12.1-RELEASE-p3 #9 r335865M: Thu Apr 16 13:18:03 CST 2020     root@epopen.com:/usr/obj/usr/src/amd64.amd64/sys/EpopenKernel
May 26 18:08:34 dns named[87177]: built with '--disable-linux-caps' '--localstatedir=/var' '--sysconfdir=/usr/local/etc/namedb' '--with-dlopen=yes' '--with-libxml2' '--with-openssl=/usr/local' '--with-readline=-L/usr/local/lib -ledit' '--with-dlz-filesystem=yes' '--enable-dnstap' '--disable-fixed-rrset' '--disable-geoip' '--without-maxminddb' '--with-gssapi=/usr/local' 'CFLAGS=-I/usr/local/include/heimdal -O2 -pipe -march=core2 -DLIBICONV_PLUG -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing ' 'LDFLAGS=-L/usr/local/lib/heimdal -Wl,-rpath,/usr/local/lib/heimdal:/usr/local/lib -L/usr/local/lib -ljson-c -fstack-protector-strong ' 'LIBS=-lkrb5 -lgssapi -L/usr/local/lib' 'KRB5CONFIG=/usr/local/bin/krb5-config' '--with-libidn2=/usr/local' '--with-json-c' '--enable-largefile' '--with-lmdb=/usr/local' '--disable-native-pkcs11' '--without-python' '--disable-querytrace' 'STD_CDEFINES=-DDIG_SIGCHASE=1' '--enable-tcp-fastopen' '--with-tuning=default' '--disable-symtable' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/share/info/' '--build=amd64-portbld-freebsd12.1' 'build_alias=amd64-portbld-freebsd12.1' 'CC=cc' 'CPPFLAGS=-DLIBICONV_PLUG -isystem /usr/local/include' 'CPP=cpp' 'PKG_CONFIG=pkgconf'
May 26 18:08:34 dns named[87177]: running as: named -u bind -c /usr/local/etc/namedb/named.conf
May 26 18:08:34 dns named[87177]: compiled by CLANG 4.2.1 Compatible FreeBSD Clang 8.0.1 (tags/RELEASE_801/final 366581)
May 26 18:08:34 dns named[87177]: compiled with OpenSSL version: OpenSSL 1.1.1g  21 Apr 2020
May 26 18:08:34 dns named[87177]: linked to OpenSSL version: OpenSSL 1.1.1g  21 Apr 2020
May 26 18:08:34 dns named[87177]: compiled with libxml2 version: 2.9.10
May 26 18:08:34 dns named[87177]: linked to libxml2 version: 20910
May 26 18:08:34 dns named[87177]: compiled with json-c version: 0.14
May 26 18:08:34 dns named[87177]: linked to json-c version: 0.14
May 26 18:08:34 dns named[87177]: compiled with zlib version: 1.2.11
May 26 18:08:34 dns named[87177]: linked to zlib version: 1.2.11
May 26 18:08:34 dns named[87177]: ----------------------------------------------------
May 26 18:08:34 dns named[87177]: BIND 9 is maintained by Internet Systems Consortium,
May 26 18:08:34 dns named[87177]: Inc. (ISC), a non-profit 501(c)(3) public-benefit
May 26 18:08:34 dns named[87177]: corporation.  Support and training for BIND 9 are
May 26 18:08:34 dns named[87177]: available at https://www.isc.org/support
May 26 18:08:34 dns named[87177]: ----------------------------------------------------
May 26 18:08:34 dns named[87177]: found 2 CPUs, using 2 worker threads
May 26 18:08:34 dns named[87177]: using 2 UDP listeners per interface
May 26 18:08:34 dns named[87177]: using up to 21000 sockets
May 26 18:08:34 dns named[87177]: loading configuration from '/usr/local/etc/namedb/named.conf'
May 26 18:08:34 dns named[87177]: reading built-in trust anchors from file '/usr/local/etc/namedb/bind.keys'
May 26 18:08:34 dns named[87177]: using default UDP/IPv4 port range: [49152, 65535]
May 26 18:08:34 dns named[87177]: using default UDP/IPv6 port range: [49152, 65535]
May 26 18:08:34 dns named[87177]: IPv6 socket API is incomplete; explicitly binding to each IPv6 address separately
May 26 18:08:34 dns named[87177]: listening on IPv6 interface lo0, ::1#53
May 26 18:08:34 dns named[87177]: listening on IPv6 interface lo0, fe80::1%1#53
May 26 18:08:34 dns named[87177]: listening on IPv4 interface lo0, 127.0.0.1#53
May 26 18:08:34 dns named[87177]: generating session key for dynamic DNS
May 26 18:08:34 dns named[87177]: sizing zone task pool based on 158 zones
May 26 18:08:34 dns named[87177]: none:100: 'max-cache-size 90%' - setting to 3521MB (out of 3912MB)
May 26 18:08:34 dns named[87177]: obtaining root key for view _default from '/usr/local/etc/namedb/bind.keys'
May 26 18:08:34 dns named[87177]: set up managed keys zone for view _default, file 'managed-keys.bind'
May 26 18:08:34 dns named[87177]: none:100: 'max-cache-size 90%' - setting to 3521MB (out of 3912MB)
May 26 18:08:34 dns named[87177]: command channel listening on ::#953
May 26 18:08:34 dns named[87177]: managed-keys-zone: loaded serial 2
May 26 18:08:34 dns named[87177]: zone 10.in-addr.arpa/IN: loaded serial 42
....
May 26 18:08:34 dns named[87177]: zone f.e.f.ip6.arpa/IN: loaded serial 42
May 26 18:08:34 dns named[87177]: all zones loaded
May 26 18:08:34 dns named[87177]: running
May 26 18:08:34 dns named[87177]: zone 1.4.9.1.0.8.4.a.1.1.0.b.1.0.0.2.ip6.arpa/IN: sending notifies (serial 2018060801)
May 26 18:08:34 dns named[87177]: zone 86.117.122.in-addr.arpa/IN: sending notifies (serial 2015110901)
May 26 18:08:34 dns named[87177]: resolver priming query complete
May 26 18:08:34 dns named[87177]: managed-keys-zone: Key 20326 for zone . is now trusted (acceptance timer complete)

It is root cause look like but I don't detail right now.
Thanks a lot.
Comment 7 epopen 2020-06-18 10:10:46 UTC
Hi Maintainer.

The issue disappeared from version 9.16.4.

Thanks all very much.