Bug 244268 - devel/py-nose: py-nose depends on python3.6 and fails to build and install on FreeBSD-11.3-STABLE
Summary: devel/py-nose: py-nose depends on python3.6 and fails to build and install on...
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-02-21 07:39 UTC by jau
Modified: 2020-03-22 07:55 UTC (History)
0 users

See Also:
koobs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jau 2020-02-21 07:39:31 UTC
Because py-nose fails also vigra and libreoffice fail to build and install
on 11.3-STABLE.

.
.
.

===>   libreoffice-6.3.4_2 depends on executable: vigra-config - not found
===>   vigra-1.11.1_7 depends on package: py36-nose>0 - not found
===>  py36-nose-1.3.7_1 Unknown flavor 'py36', possible flavors: py37 py27..
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/devel/py-nose
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/graphics/vigra
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/graphics/vigra
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/editors/libreoffice
*** Error code 1

Stop.
make: stopped in /usr/ports/editors/libreoffice
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-21 10:15:46 UTC
Thank you for your report. Could you please provide additional information, including:

- Exact FreeBSD version (uname -a)
- pkg version -v output (as an attachment)
- contents of /etc/make.conf (as an attachment)
- The full log (including complete command line used) of the build (as an attachment
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-22 07:55:58 UTC
If this is still reproducible with a supported FreeBSD version using a supported ports tree or package set (latest or quarterly), please re-open this issue with the additional information requested in comment #1