Bug 244288 - www/redmine4: Update to 4.0.6
Summary: www/redmine4: Update to 4.0.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Mikael Urankar
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-21 20:30 UTC by nork
Modified: 2020-02-28 16:09 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (mikael)


Attachments
redmine4's patch file (1.92 KB, patch)
2020-02-21 20:30 UTC, nork
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description nork 2020-02-21 20:30:10 UTC
Created attachment 211808 [details]
redmine4's patch file

- Update 4.0.6.
- Fix BROKEN by bug #244269 and bug #244270.

Reason of BROKEN(now):
  www/redmine4 +----------------> graphics/rubygem-rmagick -----> graphics/ImageMagick6
               |
               |
               +-> www/rails52 -> graphics/rubygem-mini_magick -> graphics/ImageMagick7

To fix this issue(bug #244269 and bug #244270):
  www/redmine4 +----------------> graphics/rubygem-rmagick -----> graphics/ImageMagick6-nox11
               |                                                   ^
               |                                                   |
               +-> www/rails52 -> graphics/rubygem-mini_magick ----+
Comment 1 Mikael Urankar freebsd_committer 2020-02-22 16:21:28 UTC
Thanks for the patch. I opened a review on phabricator with a different approach:
https://reviews.freebsd.org/D23682. I'll try to get the update committed next week.
Comment 2 commit-hook freebsd_committer 2020-02-28 16:09:29 UTC
A commit references this bug:

Author: mfechner
Date: Fri Feb 28 16:09:17 UTC 2020
New revision: 527337
URL: https://svnweb.freebsd.org/changeset/ports/527337

Log:
  Update to 4.0.6.
  Disable the RMAGIC option, it causes conflict with different versions of imagemagick. This problem is fixed in redmine 4.1, hopefully they'll backport the fix to the 4.0 branch.
  Use the correct redmine version when building redmine plugins.

  Mark www/redmine as deprecated with end of 2020Q2 to give maintainer enough time to upgrade everything to redmine4.
  Redmine version 3 should not be included in 2020Q3 anymore.

  PR:		244288
  Submitted by:	mikael@
  Reported by:	nork@ninth-nine.com
  Reviewed by:	mfechner@
  Differential Revision:	https://reviews.freebsd.org/D23682

Changes:
  head/www/redmine/Makefile
  head/www/redmine4/Makefile
  head/www/redmine4/bsd.redmine.mk
  head/www/redmine4/distinfo
  head/www/redmine4/files/patch-Gemfile
Comment 3 Matthias Fechner freebsd_committer 2020-02-28 16:09:55 UTC
Comitted, thanks a lot!