Bug 244292 - net/rabbitmq: Fails to install: pw: user 'rabbitmq' disappeared during update, pkg: PRE-INSTALL script failed
Summary: net/rabbitmq: Fails to install: pw: user 'rabbitmq' disappeared during update...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Erlang FreeBSD Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-22 00:10 UTC by unitrunker
Modified: 2020-02-22 03:42 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (erlang)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description unitrunker 2020-02-22 00:10:33 UTC
The following attempt was done one 12.0-RELEASE.

# pkg install rabbitmq
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking integrity... done (0 conflicting)
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        rabbitmq: 3.8.1_1

Number of packages to be installed: 1

The process will require 13 MiB more space.

Proceed with this action? [y/N]: y
[1/1] Installing rabbitmq-3.8.1_1...
===> Creating groups.
Using existing group 'rabbitmq'.
===> Creating users
Creating user 'rabbitmq' with uid '135'.
pw: user 'rabbitmq' disappeared during update
install: unknown user rabbitmq
pkg: PRE-INSTALL script failed
Comment 1 unitrunker 2020-02-22 03:01:31 UTC
disregard.

After rebuilding master.passwd (pwd_mkdb -p /etc/master.passwd) - the error ceased.
Comment 2 unitrunker 2020-02-22 03:02:21 UTC
Closing as this is not a bug!