Bug 244338 - x11-servers/xorg-server: 1.20.7 with x11/nvidia-driver results in non-functional OpenGL
Summary: x11-servers/xorg-server: 1.20.7 with x11/nvidia-driver results in non-functio...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-23 15:43 UTC by Rainer Hurling
Modified: 2020-02-24 20:25 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Hurling 2020-02-23 15:43:43 UTC

    
Comment 1 Rainer Hurling 2020-02-23 15:53:55 UTC
After installing x11-servers/xorg-server to newest version 1.20.7 on HEAD with x11/nvidia-driver installed, I always get the following message, when trying to start applications with OpenGL needs like Firefox, glxinfo, ...:

----------------------------------------------------------------------
OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.
----------------------------------------------------------------------


This is no VM, but a real box (tm). xorg-server is built with udev, mouse and keyboard work.

In /var/log/Xorg.0.log two glx libs are registered:

[ 14664.059] (II) LoadModule: "glx"
[ 14664.059] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[ 14664.060] (II) Module glx: vendor="X.Org Foundation"
[ 14664.060]    compiled for 1.20.7, module version = 1.0.0
[ 14664.060]    ABI class: X.Org Server Extension, version 10.0

[ 14664.061] (II) Loading sub module "glxserver_nvidia"
[ 14664.061] (II) LoadModule: "glxserver_nvidia"
[ 14664.061] (II) Loading /usr/local/lib/xorg/modules/extensions/libglxserver_nvidia.so
[ 14664.065] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"
[ 14664.065]    compiled for 1.6.99.901, module version = 1.0.0
[ 14664.065]    Module class: X.Org Server Extension
[ 14664.065] (II) NVIDIA GLX Module  440.31  Sun Oct 27 02:11:10 UTC 2019


nvidia-driver and mesa-libs versions of glx are both under:

#ll /usr/local/lib/xorg/modules/extensions/
total 13228
drwxr-xr-x  2 root  wheel  -      512  2020-02-23 15:43:01  .xorg
-rwxr-xr-x  2 root  wheel  -   335360  2020-02-23 14:54:12  libglx.so
lrwxr-xr-x  1 root  wheel  -       24  2020-02-23 16:12:18  libglxserver_nvidia.so -> libglxserver_nvidia.so.1
-r--r--r--  1 root  wheel  - 13161960  2020-02-23 16:12:18  libglxserver_nvidia.so.1


I have no clue, what is going wrong here. Please tell me, if I should provide more info or test something. Thanks in advance.
Comment 2 Rainer Hurling 2020-02-24 20:25:26 UTC
It turns out, that this failure occurs because of an erroneously installed emulators/virtualbox-ose-additions on the host itself. With this port installed, applications which try to use GL, fail with 'OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.'

Sorry for the noise. Nothing was wrong here with x11-servers/xorg-server or x11/nvidia-driver concerning GL functionality.