Bug 244372 - devel/libvirt-glib: replace dependency from python 2.7 to default 3.7
Summary: devel/libvirt-glib: replace dependency from python 2.7 to default 3.7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Roman Bogorodskiy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-24 15:59 UTC by VVD
Modified: 2020-04-13 03:40 UTC (History)
0 users

See Also:
novel: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description VVD 2020-02-24 15:59:24 UTC
devel/libvirt-glib/Makefile:
-USES=           gettext gmake gnome libtool pathfix pkgconfig python:2.7
+USES=           gettext gmake gnome libtool pathfix pkgconfig python

Tested build on 12.1 amd64.
Comment 1 commit-hook freebsd_committer 2020-04-13 03:39:52 UTC
A commit references this bug:

Author: novel
Date: Mon Apr 13 03:39:22 UTC 2020
New revision: 531572
URL: https://svnweb.freebsd.org/changeset/ports/531572

Log:
  devel/libvirt-glib: update to 3.0.0

   - Update to 3.0.0
   - Switch from python2.7 to default 3.7 [1]

  PR:		244372 [1]
  Submitted by:	VVD <vvd@unislabs.com> [1]

Changes:
  head/devel/libvirt-glib/Makefile
  head/devel/libvirt-glib/distinfo
  head/devel/libvirt-glib/pkg-plist
Comment 2 Roman Bogorodskiy freebsd_committer 2020-04-13 03:40:28 UTC
Committed, thanks!