Bug 244387 - sysutils/iocage: Respect PREFIX (when PREFIX != LOCALBASE)
Summary: sysutils/iocage: Respect PREFIX (when PREFIX != LOCALBASE)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Michael Gmelin
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2020-02-25 01:11 UTC by John Hein
Modified: 2020-03-22 15:21 UTC (History)
2 users (show)

See Also:
grembo: maintainer-feedback+
grembo: merge-quarterly-


Attachments
[patch] fix for non-default PREFIX (1.44 KB, patch)
2020-02-25 01:11 UTC, John Hein
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Hein 2020-02-25 01:11:31 UTC
Created attachment 211918 [details]
[patch] fix for non-default PREFIX

If you build sysutils/iocage with a non-default PREFIX, check-plist fails.

% make check-plist
 .
 .
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: %%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/PKG-INFO
Error: Orphaned: %%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/SOURCES.txt
Error: Orphaned: %%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/dependency_links.txt
Error: Orphaned: %%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/entry_points.txt
Error: Orphaned: %%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/requires.txt
Error: Orphaned: %%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/top_level.txt
===> Checking for items in pkg-plist which are not in STAGEDIR
Error: Missing: /usr/loc/%%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/PKG-INFO
Error: Missing: /usr/loc/%%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/SOURCES.txt
Error: Missing: /usr/loc/%%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/dependency_links.txt
Error: Missing: /usr/loc/%%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/entry_points.txt
Error: Missing: /usr/loc/%%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/requires.txt
Error: Missing: /usr/loc/%%PYTHON_SITELIBDIR%%/iocage_lib-1.2-py%%PYTHON_VER%%.egg-info/top_level.txt
===> Error: Plist issues found.
===> Warning: Test was done with PREFIX != LOCALBASE
===> Warning: The port may not be properly installing into PREFIX
*** Error code 1


The attached patch fixes it.

QA tested with poudriere testport.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-25 07:59:41 UTC
Thanks John 

We should probably do a check in the tree for other/all instances of this issue (not using PREFIX-safe PYTHON_SITELIBDIR), and solve them all in one go in a subsequent issue, adding portlint checks (or sanity.mk checks) to prevent them in future as well

Hit me up on IRC if you're keen :)
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-25 08:01:43 UTC
Having said that, issues like this usually indicate a packaging issue, where some files are not included in the --record output of setup.py's install command (which we use in the framework), so the root cause/resolution of this is to rectify that
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-25 08:02:11 UTC
Comment on attachment 211918 [details]
[patch] fix for non-default PREFIX

Approved by: portmgr (blanket: framework/ports (python) compliance)
Comment 4 Automation User 2020-03-11 00:25:48 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/125120666
Comment 5 commit-hook freebsd_committer 2020-03-22 15:20:17 UTC
A commit references this bug:

Author: grembo
Date: Sun Mar 22 15:19:29 UTC 2020
New revision: 528922
URL: https://svnweb.freebsd.org/changeset/ports/528922

Log:
  Respect PREFIX (when PREFIX != LOCALBASE)

  PR:		244387
  Submitted by:	John Hein <jcfyecrayz@liamekaens.com>
  Reviewed by:	koobs
  Approved by:	portmgr (blanket: framework/ports (python) compliance)

Changes:
  head/sysutils/iocage/Makefile
Comment 6 Michael Gmelin freebsd_committer 2020-03-22 15:21:02 UTC
Sorry for committing this so late. When I saw koobs comment fly by in an email (Approved by: portmgr (blanket: framework/ports (python) compliance), I somehow thought I committed it too.

I won't bother to MFH, as we're only a week from a new quarterly branch.