Bug 244393 - Failing test case: sys.netpfil.pf.fragmentation.v6
Summary: Failing test case: sys.netpfil.pf.fragmentation.v6
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: tests (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: Li-Wen Hsu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-25 05:20 UTC by Li-Wen Hsu
Modified: 2020-02-26 12:09 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Li-Wen Hsu freebsd_committer 2020-02-25 05:20:20 UTC
Since https://ci.freebsd.org/job/FreeBSD-head-amd64-test/14400/testReport/junit/sys.netpfil.pf/fragmentation/v6/

Error Message

atf-check failed; see the output of the test for details

Standard Output

net.inet6.ip6.forwarding: 0 -> 1
add net 2001:db8:42::/64: gateway 2001:db8:43::2 fib 0
add net 2001:db8:43::/64: gateway 2001:db8:42::2 fib 0
Executing command [ ping6 -c 1 2001:db8:42::2 ]
Executing command [ ping6 -c 1 -s 4500 2001:db8:42::2 ]

Standard Error

Test case metadata
------------------

allowed_architectures is empty
allowed_platforms is empty
description = IPv6 fragmentation test
has_cleanup = true
is_exclusive = false
required_configs is empty
required_disk_space = 0
required_files is empty
required_memory = 0
required_programs = scapy
required_user = root
timeout = 300

Timing information
------------------

Start time: 2020-02-20T18:58:35.737320Z
End time:   2020-02-20T18:58:47.039157Z
Duration:   11.302s

Original stderr
---------------

pf enabled
rules cleared
nat cleared
0 tables deleted.
0 states cleared
source tracking entries cleared
pf: statistics cleared
pf: interface flags reset
Fail: incorrect exit status: 2, expected: 0
stdout:
PING6(4548=40+8+4500 bytes) 2001:db8:42::1 --> 2001:db8:42::2

--- 2001:db8:42::2 ping6 statistics ---
1 packets transmitted, 0 packets received, 100.0% packet loss

stderr:

Files left in work directory after failure: created_interfaces.lst, created_jails.lst
Comment 1 commit-hook freebsd_committer 2020-02-25 11:57:02 UTC
A commit references this bug:

Author: lwhsu
Date: Tue Feb 25 11:56:55 UTC 2020
New revision: 358309
URL: https://svnweb.freebsd.org/changeset/base/358309

Log:
  Temporarily skip failing test case sys.netpfil.pf.fragmentation.v6

  PR:		244393
  Sponsored by:	The FreeBSD Foundation

Changes:
  head/tests/sys/netpfil/pf/fragmentation.sh
Comment 2 Bjoern A. Zeeb freebsd_committer 2020-02-25 12:03:35 UTC
It would be really helpful to know which the last good SVN rev was and the first one we know it was failing.

I could not figure that out easily from the web.  The changes which were on the referenced failure were all entirely unrelated to PF and networking.  So I am confused.
Comment 3 Kristof Provost freebsd_committer 2020-02-25 12:52:29 UTC
This appears to be due to  https://svnweb.freebsd.org/changeset/base/358167.
Comment 4 commit-hook freebsd_committer 2020-02-25 15:04:19 UTC
A commit references this bug:

Author: bz
Date: Tue Feb 25 15:03:41 UTC 2020
New revision: 358311
URL: https://svnweb.freebsd.org/changeset/base/358311

Log:
  ip6_output: fix regression introduced in r358167 for ipv6 fragmentation

  When moving the calculations for the optlen into the if (opt) block
  which deals with possible extension headers I failed to initialise
  unfragpartlen to the ipv6 header length if there were no extension
  headers present.  Correct that mistake to make IPv6 fragment length
  calculcations work again.

  Reported by:	hselasky, kp
  OKed by:	hselasky, kp
  MFC after:	3 days
  X-MFC with:	r358167
  PR:		244393

Changes:
  head/sys/netinet6/ip6_output.c
Comment 5 Li-Wen Hsu freebsd_committer 2020-02-25 16:31:53 UTC
Hey, thanks for noticing and fixing this ticket. This one is more like a reminder for myself.  I haven’t done the analysis myself and that’s why I haven’t assigned this to anyone.  Next time I’ll assign to myself first.  Sorry for the confusing.
Comment 6 commit-hook freebsd_committer 2020-02-26 04:55:16 UTC
A commit references this bug:

Author: lwhsu
Date: Wed Feb 26 04:54:51 UTC 2020
New revision: 358324
URL: https://svnweb.freebsd.org/changeset/base/358324

Log:
  Revert r358309 after r358311.

  PR:		244393
  Sponsored by:	The FreeBSD Foundation

Changes:
  head/tests/sys/netpfil/pf/fragmentation.sh
Comment 7 Li-Wen Hsu freebsd_committer 2020-02-26 12:09:58 UTC
Fix confirmed.