Bug 244394 - science/2d-rewriter: Reset maintainer, Update to 1.6
Summary: science/2d-rewriter: Reset maintainer, Update to 1.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2020-02-25 07:21 UTC by Igor Serikov
Modified: 2020-03-29 09:15 UTC (History)
2 users (show)

See Also:


Attachments
The .shar file (4.10 KB, text/plain)
2020-02-26 05:15 UTC, Igor Serikov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Serikov 2020-02-25 07:21:28 UTC

    
Comment 1 Igor Serikov 2020-02-25 07:26:44 UTC
I am the author of science/2d-rewriter. I do not FreeBSD machine right now. Please set PORTVERSION= to match GitHub tag 1.6. PORTREVISION= could be removed (right?).

Yet, I would like to reassign the port to ports@freebsd.org as I cannot use @acm.org and I have no email alias MAINTAINER= field.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-25 07:47:22 UTC
@Reporter If you could provide a patch (unified diff) with the proposed changes that would be greatly appreciated
Comment 3 Igor Serikov 2020-02-26 05:15:24 UTC
Created attachment 211944 [details]
The .shar file
Comment 4 Igor Serikov 2020-02-26 05:15:45 UTC
Adding the .shar.
Comment 5 Bartek Rutkowski freebsd_committer 2020-03-03 12:18:40 UTC
Updates to the ports should be provided in the form of diff files, as opposed to new ports submissions, that should use shar archives. However, the most important part is for the update to come from the email address of the port maintainer.
Comment 6 commit-hook freebsd_committer 2020-03-26 18:27:09 UTC
A commit references this bug:

Author: makc
Date: Thu Mar 26 18:26:50 UTC 2020
New revision: 529204
URL: https://svnweb.freebsd.org/changeset/ports/529204

Log:
  science/2d-rewriter:
  - Update to 1.6
  - Drop maintainership
  - while I'm here reformat descrption, add WWW, clean up Makefile

  PR:		244394 (based on)
  Submitted by:	Igor Serikov (maintainer)

Changes:
  head/science/2d-rewriter/Makefile
  head/science/2d-rewriter/distinfo
  head/science/2d-rewriter/pkg-descr
Comment 7 Max Brazhnikov freebsd_committer 2020-03-26 18:27:48 UTC
Committed, thanks!
Comment 8 Igor Serikov 2020-03-29 03:10:45 UTC
(In reply to Max Brazhnikov from comment #7)
Thank you!
Although, MAINTAINER= still points to my ACM address that I am going to loose this month as I explained in https://lists.freebsd.org/pipermail/freebsd-bugs/2020-March/093270.html. The problem is neither FreeBSD nor GitHub offer an email alias to use a public email. Of course, anybody can always reach the developer of any GitHub project through the website but this is not an email that you can use elsewhere.
Comment 9 Max Brazhnikov freebsd_committer 2020-03-29 09:15:55 UTC
(In reply to Igor Serikov from comment #8)
Done, thanks for heads up. That's why we ask for unified diffs.