Bug 244462 - sysutils/fusefs-exfat source code package not found in distfiles directory.
Summary: sysutils/fusefs-exfat source code package not found in distfiles directory.
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Oleksii Samorukov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-27 06:43 UTC by Brian Zou
Modified: 2020-05-03 10:08 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (samm)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Zou 2020-02-27 06:43:58 UTC
## Ports error:

[zoujiaqing@freebsd /usr/ports/sysutils/fusefs-exfat]$ sudo make install clean
Password:
===>  License GPLv2+ MSPAT needs confirmation, will ask later
===>   fusefs-exfat-1.3.0 depends on file: /usr/local/sbin/pkg - found
=> relan-exfat-v1.3.0_GH0.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://codeload.github.com/relan/exfat/tar.gz/v1.3.0?dummy=/relan-exfat-v1.3.0_GH0.tar.gz
env: axel: No such file or directory
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/relan-exfat-v1.3.0_GH0.tar.gz
env: axel: No such file or directory
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/ and try again.
*** Error code 1

Stop.
make: stopped in /usr/ports/sysutils/fusefs-exfat

## Resolve for wget

wget https://github.com/relan/exfat/archive/v1.3.0.tar.gz
cp v1.3.0.tar.gz /usr/ports/distfiles/relan-exfat-v1.3.0_GH0.tar.gz

## Please

Add fusefs-exfat to pkg mirror? I want use `pkg install fusefs-exfat` to install it.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2020-02-27 14:02:26 UTC
Fix Summary.

Note to submitter: fetch works here on my test machine.
Comment 2 Oleksii Samorukov freebsd_committer 2020-05-03 10:08:27 UTC
Works for me:

===>  License GPLv2+ MSPAT needs confirmation, will ask later
===>   fusefs-exfat-1.3.0 depends on file: /usr/local/sbin/pkg - found
=> relan-exfat-v1.3.0_GH0.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://codeload.github.com/relan/exfat/tar.gz/v1.3.0?dummy=/relan-exfat-v1.3.0_GH0.tar.gz
fetch: https://codeload.github.com/relan/exfat/tar.gz/v1.3.0?dummy=/relan-exfat-v1.3.0_GH0.tar.gz: size unknown
fetch: https://codeload.github.com/relan/exfat/tar.gz/v1.3.0?dummy=/relan-exfat-v1.3.0_GH0.tar.gz: size of remote file is not known
relan-exfat-v1.3.0_GH0.tar.gz                           56 kB  338 kBps    00s
===> Fetching all distfiles required by fusefs-exfat-1.3.0 for building

Looks like you have some local issues