Bug 244463 - lang/python37: Remove the LIBFFI option
Summary: lang/python37: Remove the LIBFFI option
Status: Closed DUPLICATE of bug 244782
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-python mailing list
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2020-02-27 07:08 UTC by Wen Heping
Modified: 2020-03-13 06:42 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (python)


Attachments
Remove the LIBFFI option (1.25 KB, text/plain)
2020-02-27 07:08 UTC, Wen Heping
no flags Details
revised patch (1.62 KB, text/plain)
2020-02-27 08:18 UTC, Wen Heping
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wen Heping freebsd_committer 2020-02-27 07:08:38 UTC
Created attachment 211984 [details]
Remove the LIBFFI option

Since python-3.7 upstream remove bundled libffi, now the build of python37 failed when LIBFFI option disable. We have to build with libffi in ports.

So LIBFFI option should be removed.
Comment 1 Wen Heping freebsd_committer 2020-02-27 08:18:43 UTC
Created attachment 211985 [details]
revised patch
Comment 2 Mathieu Arnold freebsd_committer 2020-02-27 08:32:41 UTC
This should be assigned to python@, I do not see what portmgr can or needs to do here.
Comment 3 Wen Heping freebsd_committer 2020-02-27 08:44:43 UTC
(In reply to Mathieu Arnold from comment #2)
Ask for a exp-run here.
Comment 4 Automation User 2020-03-13 00:11:13 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/125885939
Comment 5 Antoine Brodin freebsd_committer 2020-03-13 06:40:31 UTC
Please put back --with-system-ffi in CONFIGURE_ARGS.
Comment 6 Antoine Brodin freebsd_committer 2020-03-13 06:42:31 UTC

*** This bug has been marked as a duplicate of bug 244782 ***