Bug 244534 - net/chrony: Fix linking to nettle and update rc.d script
Summary: net/chrony: Fix linking to nettle and update rc.d script
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Matthias Andree
URL:
Keywords: buildisok
: 242510 (view as bug list)
Depends on: 242510 245399
Blocks:
  Show dependency treegraph
 
Reported: 2020-03-01 06:19 UTC by Colin T.
Modified: 2020-04-06 16:30 UTC (History)
3 users (show)

See Also:
mandree: maintainer-feedback+


Attachments
patch (1.58 KB, patch)
2020-03-01 06:19 UTC, Colin T.
no flags Details | Diff
patch-1 (1.72 KB, patch)
2020-03-02 07:51 UTC, Colin T.
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Colin T. 2020-03-01 06:19:10 UTC
Created attachment 212066 [details]
patch

Always require pkgconfig instead of only requiring it for NSS
Add pidfile to rc.d script to stop it from complaining when stopping chronyd.
Document chronyd_* options in rc.d script.
Comment 1 Automation User 2020-03-01 06:36:28 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/122227075
Comment 2 Colin T. 2020-03-02 07:51:55 UTC
Created attachment 212095 [details]
patch-1

Bump PORTREVISION.
Comment 3 Automation User 2020-03-17 00:07:15 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/126854034
Comment 4 Matthias Andree freebsd_committer 2020-04-04 16:27:39 UTC
Hi Colin, what is the purpose of the pkgconfig change, why is it needed? With every option on except NSS, I don't seem to need it.
Comment 5 Colin T. 2020-04-05 16:08:24 UTC
(In reply to Matthias Andree from comment #4)

Without pkgconfig, chrony will build fine but won't link to nettle.
Comment 6 Matthias Andree freebsd_committer 2020-04-05 20:54:19 UTC
*** Bug 242510 has been marked as a duplicate of this bug. ***
Comment 7 commit-hook freebsd_committer 2020-04-05 21:20:58 UTC
A commit references this bug:

Author: mandree
Date: Sun Apr  5 21:20:11 UTC 2020
New revision: 530840
URL: https://svnweb.freebsd.org/changeset/ports/530840

Log:
  net/chrony: make NETTLE build robust, improve rc script, re-enable NSS

  Changes by Colin T.:
  * Always require pkgconfig instead of only requiring it for NSS,
    because otherwise chrony does not link reliably to nettle. [1]
  * Add pidfile to rc.d script to stop it from complaining when
    stopping chronyd. [1]
  * Document chronyd_* options in rc.d script. [1]

  Changes by Matthias Andree:
  * Move USES line up to please portlint.
  * Add HTMLDOCS option, to build and install HTML docs. IMPLIES DOCS.
    Needs textproc/asciidoctor (rubygem) as build requisite.
  * Turn CRYPTLIB into a _RADIO to choose at most one from NSS + NETTLE.
  * Under WITH_DEBUG, add --enable-debug to CONFIGURE_ARGS.
  * Remove @ (silent) from Makefile commands.
  * Remove NSS_BROKEN, chrony 3.5 appears to work with NSS. Updates [3].

  PR:		244534 [1]
  PR:		242510 [2]
  PR:		223840 [3]
  Submitted by:	Colin T. <bugzilla@nulldir.e4ward.com> [1]
  Reported by:	Matt Smith <freebsd@xtaz.uk> [2]
  Approved by:	maintainer timeout (yonas@fizk.net, 36 days)

Changes:
  head/net/chrony/Makefile
  head/net/chrony/files/chronyd.in
  head/net/chrony/pkg-plist
Comment 8 Matthias Andree freebsd_committer 2020-04-05 21:22:12 UTC
Colin, understood and confirmed with poudriere. Building directly from the port picked up nettle for some reason.

I have taken the opportunity to mess with the OPTIONS quite a bit to more thoroughly reflect the package behaviour in the options.

Thank you for submitting the patch!