Bug 244542 - www/searx: Correct USES=python <version-spec> (Supports 3.x)
Summary: www/searx: Correct USES=python <version-spec> (Supports 3.x)
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: needs-qa
: 244687 (view as bug list)
Depends on: 244540 244541 244528
Blocks:
  Show dependency treegraph
 
Reported: 2020-03-01 12:26 UTC by Christopher May-Townsend
Modified: 2020-03-09 10:58 UTC (History)
4 users (show)

See Also:
loic.blot: maintainer-feedback+


Attachments
python3 support + revision bump (574 bytes, patch)
2020-03-01 12:26 UTC, Christopher May-Townsend
no flags Details | Diff
Disable imperative to use python2 only (569 bytes, patch)
2020-03-09 07:43 UTC, Christopher May-Townsend
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher May-Townsend 2020-03-01 12:26:49 UTC
Created attachment 212076 [details]
python3 support + revision bump

Since this is the last version with python 2 support, im submitting the tiny change to allow python3 support. 

I've submitted 2 other tickets for the 2 deps that dont have py3 support yet and ill link them to the ticket. Not sure if this will need a revision bump or not for the version. I'll assume yes and also assume this will be merged after the version bump in 244528.
Comment 1 Zane C. Bowers-Hadley 2020-03-09 05:35:35 UTC
*** Bug 244687 has been marked as a duplicate of this bug. ***
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-09 06:11:13 UTC
If this versions supports 2.x (along with 3.x), the correct USES=python <version-spec> is USES=python (implying any version is supported). <version-spec> is to be used declaratively, not imperatively
Comment 3 Christopher May-Townsend 2020-03-09 07:43:47 UTC
Created attachment 212277 [details]
Disable imperative to use python2 only

Since python 2 is supported for 0.16, patch resent for inclusion of python 2 & 3
Comment 4 Christopher May-Townsend 2020-03-09 07:44:07 UTC
Good point, since this version still does support 2, patch resubmitted