Bug 244650 - devel/py-ioflo: Update to 2.0.0, update python depends to 3.7+
Summary: devel/py-ioflo: Update to 2.0.0, update python depends to 3.7+
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ben Woods
URL:
Keywords: buildisok, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2020-03-07 02:33 UTC by Ben Woods
Modified: 2020-04-01 22:34 UTC (History)
1 user (show)

See Also:
woodsb02: maintainer-feedback-
woodsb02: merge-quarterly-


Attachments
Patch to update devel/py-ioflo to v2.0.0 (1.19 KB, patch)
2020-03-07 02:33 UTC, Ben Woods
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Woods freebsd_committer 2020-03-07 02:33:27 UTC
Created attachment 212212 [details]
Patch to update devel/py-ioflo to v2.0.0

devel/py-ioflo: Update to 2.0.0, update python depends to 3.7+

Changes this release:
  https://github.com/ioflo/ioflo/blob/v2.0.0/ChangeLog.md
Comment 1 Ben Woods freebsd_committer 2020-03-07 02:36:21 UTC
Hi Christer - do you think the time is right for this update, noting it drops python 2.7 support?

Status note - waiting for maintainer feedback
Comment 2 Automation User 2020-03-22 00:05:25 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/128484181
Comment 3 Ben Woods freebsd_committer 2020-04-01 22:29:20 UTC
Maintainer timeout - proceeding with commit
Comment 4 commit-hook freebsd_committer 2020-04-01 22:33:16 UTC
A commit references this bug:

Author: woodsb02
Date: Wed Apr  1 22:32:20 UTC 2020
New revision: 530249
URL: https://svnweb.freebsd.org/changeset/ports/530249

Log:
  devel/py-ioflo: Update to 2.0.0, update python depends to 3.7+

  Changes this release:
    https://github.com/ioflo/ioflo/blob/v2.0.0/ChangeLog.md

  PR:		244650
  Approved by:	Christer Edwards (maintainer timeout)

Changes:
  head/devel/py-ioflo/Makefile
  head/devel/py-ioflo/distinfo
Comment 5 Ben Woods freebsd_committer 2020-04-01 22:34:17 UTC
Committed. No need to backport to quarterly, since it is not a bug fix or security update.