Bug 244653 - net/py-raet: Fix USES=python <version-spec> (supports Python 3.x)
Summary: net/py-raet: Fix USES=python <version-spec> (supports Python 3.x)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Ben Woods
URL: https://github.com/RaetProtocol/raet/...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-07 03:32 UTC by Ben Woods
Modified: 2020-05-16 05:59 UTC (History)
2 users (show)

See Also:
woodsb02: maintainer-feedback-
koobs: merge-quarterly?


Attachments
Patch for net/py-raet - Update USES=python to include python3 (622 bytes, patch)
2020-03-07 03:32 UTC, Ben Woods
koobs: maintainer-approval? (christer.edwards)
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Woods freebsd_committer 2020-03-07 03:32:13 UTC
Created attachment 212215 [details]
Patch for net/py-raet - Update USES=python to include python3

net/py-raet: Update USES=python to include python3

Python3 support was added in raet version 0.5.0:
https://github.com/RaetProtocol/raet/blob/master/ChangeLog.md#20150204-2
Comment 1 Ben Woods freebsd_committer 2020-03-07 03:33:20 UTC
Hi Christer / Koobs,
Can I please get your thoughts on this change?
I can't find anything more specific about exact python3 versions supported.
Regards,
Ben
Comment 2 Chris Hutchinson 2020-03-07 04:01:05 UTC
(In reply to Ben Woods from comment #1)
FWIW if you mean ports, and have a ports tree
handy. All that magic is located in Mk/Uses
eg; Mk/Uses/python.mk

So USES=    python3+

will provide support (currently) for
versions 3.5 - 3.8

HTH

--Chris
Comment 3 Ben Woods freebsd_committer 2020-03-07 04:10:11 UTC
(In reply to Chris Hutchinson from comment #2)
Hi Chris,
The issue is that this port previously claimed to only support python 2.7, but actually the upstream code also supports python3.

Hence the value of USES=python needs to be updated in this port to reflect upstream, as per the attached patch.

I can't find any more specific details upstream about which exact versions of python3 are supported (e.g. does their code work with python 3.6, 3.7 and 3.8?)
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-07 13:50:29 UTC
(In reply to Ben Woods from comment #3)

At least Python 3.5 [1]

The key here is going to be getting the tests running for the port (test_depends / test target) and reaching out to upstream to confirm.

[1] https://github.com/RaetProtocol/raet/commit/19391b599cdde2399889522c442f6bd779525ce3
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-07 13:51:41 UTC
Comment on attachment 212215 [details]
Patch for net/py-raet - Update USES=python to include python3

Approved by: portmgr (blanket: dependency fix, ports (python) compliance)
MFH: 2020Q1
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-07 13:52:10 UTC
Make that at least 3.6 [1]

https://github.com/RaetProtocol/raet/commit/16a05b81daaaa8ec7933719e312b5f0274ee3ade
Comment 7 Ben Woods freebsd_committer 2020-03-08 23:12:30 UTC
I have reached out to upstream by submitting an issue on their GitHub:
https://github.com/RaetProtocol/raet/issues/12
Comment 8 commit-hook freebsd_committer 2020-03-08 23:17:20 UTC
A commit references this bug:

Author: woodsb02
Date: Sun Mar  8 23:16:22 UTC 2020
New revision: 528084
URL: https://svnweb.freebsd.org/changeset/ports/528084

Log:
  net/py-raet: Update USES=python to include python3

  Python3 support was added in raet version 0.5.0:
  https://github.com/RaetProtocol/raet/blob/master/ChangeLog.md#20150204-2

  Exactly which python 3 versions are supported / known to work will be
  discussed here:
  https://github.com/RaetProtocol/raet/issues/12

  We know at least python 3.5 and 3.6 are supported:
  https://github.com/RaetProtocol/raet/commit/19391b599cdde2399889522c442f6bd779525ce3
  https://github.com/RaetProtocol/raet/commit/16a05b81daaaa8ec7933719e312b5f0274ee3ade

  PR:		244653, 243610
  Submitted by:	Tommy P <tommyhp2@gmail.com>
  Approved by:	portmgr (blanket: dependency fix, ports (python) compliance)
  MFH:		2020Q1

Changes:
  head/net/py-raet/Makefile
Comment 9 Ben Woods freebsd_committer 2020-03-08 23:17:40 UTC
Committed to head. I might wait a few days before MFH to see if we get any response from upstream first.
Comment 10 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-09 02:26:32 UTC
(In reply to commit-hook from comment #8)

Thanks Ben!
Comment 11 Ben Woods freebsd_committer 2020-05-16 05:59:13 UTC
Committed, and MFH not necessary since 2020Q2 ports quarterly branch now exists - thanks for your input koobs.