Bug 244723 - www/node12: Update to to 12.16.1 (fixes security vulnerabilities)
Summary: www/node12: Update to to 12.16.1 (fixes security vulnerabilities)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: Bradley T. Hughes
URL:
Keywords: needs-qa, security
Depends on:
Blocks:
 
Reported: 2020-03-10 15:47 UTC by Miroslav Lachman
Modified: 2020-04-12 22:49 UTC (History)
1 user (show)

See Also:
bhughes: maintainer-feedback+
bhughes: merge-quarterly+


Attachments
update of port to 12.16.1 (970 bytes, patch)
2020-03-10 15:47 UTC, Miroslav Lachman
no flags Details | Diff
poudriere testport build log success for 11.3-RELEASE (102.06 KB, application/gzip)
2020-03-10 21:33 UTC, Miroslav Lachman
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav Lachman 2020-03-10 15:47:39 UTC
Created attachment 212310 [details]
update of port to 12.16.1

Current node12 version in port 12.14.1 is vulnerable.
Update port to latest upstream version 12.16.1
Comment 1 Miroslav Lachman 2020-03-10 21:33:26 UTC
Created attachment 212316 [details]
poudriere testport build log success for 11.3-RELEASE

Only build tested.
Is there any nodejs run test suite available?
Comment 2 Miroslav Lachman 2020-03-27 10:39:52 UTC
Another fix was already committed.
Will it be merged to Quaterly branch?
Comment 3 Bradley T. Hughes freebsd_committer 2020-04-12 22:49:46 UTC
I am closing this, since 12.16.1 is now in the the newest quarterly. I'm sorry that I didn't get around to merging it to the 2020Q1 branch.