Bug 244730 - x11-servers/xorg-server : when fetching sources : You cannot select multiple options from the CONF radio (on FreeBSD 12.1-RELEASE-p1)
Summary: x11-servers/xorg-server : when fetching sources : You cannot select multiple ...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: powerpc Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-11 07:19 UTC by canardo
Modified: 2020-04-15 20:04 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description canardo 2020-03-11 07:19:15 UTC
Problem found when fetching port sources for x11-servers/xorg-server on FreeBSD 12.1-RELEASE-p1 r354992 GENERIC powerpc 32 bit, running on Apple Powerbook 17".


# cd /usr/ports/x11-servers/xorg-server/
# make fetch-recursive
===> Fetching all distfiles for xorg-server-1.20.7_2,1 and dependencies
===>  License MIT accepted by the user
====> You cannot select multiple options from the CONF radio
=====> Only one of these must be defined: DEVD UDEV
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/x11-servers/xorg-server
*** Error code 1

Stop.
make: stopped in /usr/ports/x11-servers/xorg-server



# make config

Default values are

│ │ [x] SUID  Install setuid wrapper to allow startx as non-root             │ │  
│ │────────────── Backend to use for input device configuration ─────────────│ │  
│ │ (*) DEVD  Use devd for autoconfiguration of input devices                │ │  
│ │+( ) UDEV  Use udev via libudev-devd for autoconfiguration of input devics


When unselecting DEDV, command 'make fetch-recursive' works OK.

Even if a workaround exists, the default values are not OK and I think, need to be fixed.
Comment 1 rkoberman 2020-03-11 16:37:02 UTC
I'm very confused by the description of the problem. You must have DEVD or UDEV selected. Using "make config", you should see DEVD selected as the default. If you select UDEV, DEVD will automatically be deselected.

I suspect that you may have previously been using the old (and once default) HALD method. The config system can have problems when defaults change or available options are changed. This is the first case I have encountered where an old radio button, once the default, had been deleted and a new option added at about the same time.

I suggest clearing out any old cruft in the stored config with "make rmconfig" and then "make config".
Comment 2 Niclas Zeising freebsd_committer 2020-03-13 08:59:46 UTC
This is not a bug in xorg-server, if anything, it's a bug in the ports framework.  As suggested, try removing the configuration altogether, before running make config again.
Comment 3 canardo 2020-03-13 12:38:13 UTC
Following 'make rmconfig' as recommended above, default values are now

/usr/ports/x11-servers/xorg-server # make config


│ │+[x] SUID  Install setuid wrapper to allow startx as non-root             │ │  
│ │────────────── Backend to use for input device configuration ─────────────│ │  
│ │+( ) DEVD  Use devd for autoconfiguration of input devices                │ │  
│ │+(*) UDEV  Use udev via libudev-devd for autoconfiguration of input devics│ │  


And build is OK.

AFAIR, previous xorg-server version was 1.18 and options have been kept by default.
So, no idea were with problem comes from, and happy to know it does not look like a bug.
Sorry for annoyance, I guess this ticket can be closed.