Bug 244782 - [exp-run] lang/python37: Update to 3.7.7 and remove the LIBFFI option
Summary: [exp-run] lang/python37: Update to 3.7.7 and remove the LIBFFI option
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Wen Heping
URL:
Keywords:
: 244463 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-03-13 04:05 UTC by Wen Heping
Modified: 2021-06-09 00:59 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (python)


Attachments
update to 3.7.7 (5.84 KB, text/plain)
2020-03-13 04:05 UTC, Wen Heping
no flags Details
Re-add --with-system-ffi (5.47 KB, text/plain)
2020-03-13 10:36 UTC, Wen Heping
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wen Heping freebsd_committer 2020-03-13 04:05:56 UTC
Created attachment 212374 [details]
update to 3.7.7

- Update to 3.7.7
- Remove the LIBFFI option
Comment 1 Antoine Brodin freebsd_committer 2020-03-13 06:42:31 UTC
*** Bug 244463 has been marked as a duplicate of this bug. ***
Comment 2 Antoine Brodin freebsd_committer 2020-03-13 06:43:49 UTC
Please :

- add back --with-system-ffi to CONFIGURE_ARGS
- provide a patch relative to ${PORTSDIR}
Comment 3 Wen Heping freebsd_committer 2020-03-13 10:36:40 UTC
Created attachment 212379 [details]
Re-add --with-system-ffi
Comment 4 Antoine Brodin freebsd_committer 2020-03-18 15:27:58 UTC
Exp-run looks fine.
Comment 5 commit-hook freebsd_committer 2020-03-19 07:19:15 UTC
A commit references this bug:

Author: wen
Date: Thu Mar 19 07:18:36 UTC 2020
New revision: 528692
URL: https://svnweb.freebsd.org/changeset/ports/528692

Log:
  - Update to 3.7.7
  - Remove the LIBFFI option

  PR:		244782
  Submitted by:	wen@(myself)
  Exp-run by:	antoine@

Changes:
  head/lang/python-doc-html/distinfo
  head/lang/python37/Makefile
  head/lang/python37/Makefile.version
  head/lang/python37/distinfo