Bug 244819 - emulators/virtualbox-ose: System freezes on VM start when using bridge mode on 13-CURRENT
Summary: emulators/virtualbox-ose: System freezes on VM start when using bridge mode o...
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: vbox (Nobody)
URL:
Keywords: crash, needs-qa
Depends on:
Blocks:
 
Reported: 2020-03-15 03:27 UTC by Neel Chauhan
Modified: 2020-09-20 14:03 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments
patch to use EPOCH in VirtualBox on 13-CURRENT (1.77 KB, patch)
2020-07-29 05:07 UTC, Neel Chauhan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan 2020-03-15 03:27:35 UTC
Whenever I start a VM on VirtualBox 5.2.34 and set the networking to bridge mode, my system freezes. This makes it impossible to test networks in VMs unless I use bhyve, which then lacks a GUI and doesn't support bridge mode on my laptop's Wi-Fi, downgrade to 12.x, or use another OS.

System: FreeBSD 13.0-CURRENT r358869 on HP ProDesk 400 G4 - i7-7700, 24GB DDR4 RAM, MSI nVidia GT 1030. I used the packages to install VirtualBox.
Comment 1 Neel Chauhan 2020-07-29 04:38:31 UTC

*** This bug has been marked as a duplicate of bug 248339 ***
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-07-29 04:50:55 UTC
^Triage Re-open earlier report
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-07-29 04:51:44 UTC
*** Bug 248339 has been marked as a duplicate of this bug. ***
Comment 4 Neel Chauhan 2020-07-29 05:05:27 UTC

*** This bug has been marked as a duplicate of bug 248339 ***
Comment 5 Neel Chauhan 2020-07-29 05:06:37 UTC
Well, re-opening.
Comment 6 Neel Chauhan 2020-07-29 05:07:10 UTC
Created attachment 216849 [details]
patch to use EPOCH in VirtualBox on 13-CURRENT
Comment 7 Neel Chauhan 2020-07-29 05:07:47 UTC
Apparently, VirtualBox does not use EPOCH on 13. My patch allows this.