Bug 244890 - graphics/mesa-dri fails to build on 13-current
Summary: graphics/mesa-dri fails to build on 13-current
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Brooks Davis
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-18 16:03 UTC by Cy Schubert
Modified: 2020-05-13 02:22 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (brooks)


Attachments
Build log (15.04 KB, text/plain)
2020-03-18 16:03 UTC, Cy Schubert
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cy Schubert freebsd_committer 2020-03-18 16:03:32 UTC
Created attachment 212500 [details]
Build log

./configure fails to detect llvm 10 in 13-CURRENT.

I looked at it briefly yesterday but in the interest of expediency I am submitting this PR.
Comment 1 Cy Schubert freebsd_committer 2020-03-18 16:03:49 UTC
The VM in question was at $JOB.
Comment 3 Jan Beich freebsd_committer 2020-03-18 16:45:21 UTC
(In reply to Cy Schubert from comment #0)
> ld-elf.so.1: Shared object "libncurses.so.8" not found, required by "libLLVM-8.so"
> ld-elf.so.1: Shared object "libncurses.so.8" not found, required by "libLLVM-8.so"
> ld-elf.so.1: Shared object "libncurses.so.8" not found, required by "libLLVM-8.so"
> ld-elf.so.1: Shared object "libncurses.so.8" not found, required by "libLLVM-8.so"

libLLVM-8.so is part of devel/llvm80. Over to the respective maintainer. 

poudriere is not affected because it rebuilds *all* packages on OSVERSION bumps.
Comment 4 Cy Schubert freebsd_committer 2020-03-18 16:46:50 UTC
Looks like it built ok in poudriere at home. Something about this VM at $JOB must trigger it. I'll dig deeper.
Comment 5 rkoberman 2020-03-19 00:41:14 UTC
libncurses.so is a part of the base system. What version it do you have in /lib? Was devel/llvm80 built locally (in which case to should be linked to libncurses in /lib) or installed from a package? Do you possibly have devel/ncurses installed?
Comment 6 Cy Schubert freebsd_committer 2020-05-13 02:22:37 UTC
It was libncurses.