Bug 244925 - devel/gcc-arm-embedded: Fix missing libiconv dependency for gdb
Summary: devel/gcc-arm-embedded: Fix missing libiconv dependency for gdb
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Lev A. Serebryakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-19 23:09 UTC by Ilia Skalozubov
Modified: 2020-03-20 09:36 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (lev)


Attachments
Add libiconv option to gdb configure args (465 bytes, patch)
2020-03-19 23:09 UTC, Ilia Skalozubov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ilia Skalozubov 2020-03-19 23:09:10 UTC
Created attachment 212539 [details]
Add libiconv option to gdb configure args

CXXLD can't link to libiconv due to a missing configure script argument:
...
ld: error: undefined symbol: libiconv_close
>>> referenced by charset.c
>>>               charset.o:(iconv_wrapper::~iconv_wrapper())
c++: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[4]: *** [Makefile:1889: gdb] Error 1
gmake[4]: Leaving directory '/usr/obj/xports/devel/gcc-arm-embedded/work/build/gdb/gdb'
gmake[3]: *** [Makefile:8792: all-gdb] Error 2
gmake[3]: Leaving directory '/usr/obj/xports/devel/gcc-arm-embedded/work/build/gdb'
gmake[2]: *** [Makefile:849: all] Error 2
gmake[2]: Leaving directory '/usr/obj/xports/devel/gcc-arm-embedded/work/build/gdb'
*** Error code 2

Stop.
make[1]: stopped in /usr/obj/xports/devel/gcc-arm-embedded/work
*** Error code 1

Stop.
make: stopped in /xports/devel/gcc-arm-embedded


How to reproduce (without waiting for several hours):
1. Go to /usr/ports/devel/gcc-arm-embedded
2. `make configure`
3. Go to ${WRKDIR}
4. `make build-gdb`

After applying the patch configure script successfully detect libiconv:
...
checking how to link with libiconv... /usr/local/lib/libiconv.so -Wl,-rpath -Wl,/usr/local/lib
...
and the port is being built without errors.

P.S.
In addition, the patch removes a duplicate of "with-lzma" option.
Comment 1 commit-hook freebsd_committer 2020-03-20 09:36:11 UTC
A commit references this bug:

Author: lev
Date: Fri Mar 20 09:36:07 UTC 2020
New revision: 528770
URL: https://svnweb.freebsd.org/changeset/ports/528770

Log:
   Fix libiconv detection for gdb.

  PR:		244925
  Submitted by:	Ilia Skalozubov <freebsd@skinc.ru>

Changes:
  head/devel/gcc-arm-embedded/Makefile
  head/devel/gcc-arm-embedded/files/Makefile
Comment 2 Lev A. Serebryakov freebsd_committer 2020-03-20 09:36:49 UTC
Thnx!