Bug 244968 - graphics/xpdf4 fix fong config crash
Summary: graphics/xpdf4 fix fong config crash
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: Cy Schubert
URL: https://bugs.archlinux.org/task/64168
Keywords: crash, needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2020-03-22 10:49 UTC by Zane C. Bowers-Hadley
Modified: 2020-05-13 02:27 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (cy)
cy: merge-quarterly-


Attachments
svn diff (1.24 KB, patch)
2020-03-22 10:49 UTC, Zane C. Bowers-Hadley
no flags Details | Diff
Option to disable fontconfig support. (830 bytes, patch)
2020-03-23 02:12 UTC, Cy Schubert
no flags Details | Diff
Option to disable fontconfig support. (831 bytes, patch)
2020-03-23 02:25 UTC, Cy Schubert
no flags Details | Diff
Option to disable fontconfig support. (821 bytes, patch)
2020-03-23 15:27 UTC, Cy Schubert
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zane C. Bowers-Hadley 2020-03-22 10:49:13 UTC
Created attachment 212607 [details]
svn diff

https://bugs.archlinux.org/task/64168

This issue seems to crop up if using XFCE.

The attached patch fixes it.

PORTEPOCH bumped so that it gets rebuilt.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-22 10:50:50 UTC
PORTREVISION should be bumped (set to 1 in this case). PORTEPOCH is for cases where a version goes backward
Comment 2 Cy Schubert freebsd_committer 2020-03-22 19:25:09 UTC
I cannot reproduce the problem here. Can you post error messages or a core file, please.
Comment 3 Zane C. Bowers-Hadley 2020-03-23 00:39:00 UTC
Error was linked to. Exact same issue as there, just with a different line number between there and the current version.

Here is another mention of the exact same issue in the current version.

This affects way more than me.


https://forum.xpdfreader.com/viewtopic.php?f=1&t=41895
Comment 4 Cy Schubert freebsd_committer 2020-03-23 01:27:06 UTC
I am not able to reproduce this problem on FreeBSD using xfce. Can you give me the exact line number for the assertion as the Linux fix suggested is incorrect.
Comment 5 Zane C. Bowers-Hadley 2020-03-23 01:39:22 UTC
Actually make it the line moved as it what ever FcFini is doing on line 571 in xpdf/GlobalParams.cc.


Assertion failed: (fcCacheChains[i] == NULL), function FcCacheFini, file fccache.c, line 823.
Comment 6 Cy Schubert freebsd_committer 2020-03-23 02:12:19 UTC
Created attachment 212633 [details]
Option to disable fontconfig support.

Can you try this, please?
Comment 7 Cy Schubert freebsd_committer 2020-03-23 02:25:30 UTC
Created attachment 212634 [details]
Option to disable fontconfig support.

Done correctly this time.
Comment 8 Zane C. Bowers-Hadley 2020-03-23 05:02:25 UTC
Howdy!

Nope. Still the same with that patch.
Comment 9 Cy Schubert freebsd_committer 2020-03-23 15:27:37 UTC
Created attachment 212646 [details]
Option to disable fontconfig support.

This undefines HAVE_FONTCONFIG. Try now.
Comment 10 Cy Schubert freebsd_committer 2020-03-24 17:19:32 UTC
Let me know if this works for you.
Comment 11 Zane C. Bowers-Hadley 2020-03-25 02:13:58 UTC
(In reply to Cy Schubert from comment #10)

Yup! That works.
Comment 12 Cy Schubert freebsd_committer 2020-03-25 02:33:07 UTC
Thanks for testing. I'll commit it next chance I get.
Comment 13 commit-hook freebsd_committer 2020-03-25 03:21:26 UTC
A commit references this bug:

Author: cy
Date: Wed Mar 25 03:11:10 UTC 2020
New revision: 529074
URL: https://svnweb.freebsd.org/changeset/ports/529074

Log:
  Circumvent an xpdf4 assertion under xfce when fontconfig is present.

  This enables users to optionally build xpdf4 without fontconfig support
  either through ports or via poudriere-options.

  PR:		244968
  Reported by:	Zane C. Bowers-Hadley <vvelox at vvelox.net>
  MFH:		2020Q1

Changes:
  head/graphics/xpdf4/Makefile
Comment 14 Cy Schubert freebsd_committer 2020-05-13 02:27:02 UTC
Fixed.