Bug 244970 - x11-themes/plasma5-breeze-gtk: Invisible radio buttons and checkboxes
Summary: x11-themes/plasma5-breeze-gtk: Invisible radio buttons and checkboxes
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL: https://bugs.kde.org/show_bug.cgi?id=...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-22 11:32 UTC by Bengt Ahlgren
Modified: 2020-03-26 04:52 UTC (History)
7 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)
tcberner: maintainer-feedback+


Attachments
plasma5-breeze-gtk.diff (7.17 KB, patch)
2020-03-24 06:15 UTC, Tobias Kortkamp
tcberner: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bengt Ahlgren 2020-03-22 11:32:37 UTC
The radio buttons in the save file dialogue disappeared when I upgraded firefox from 73.0 to 74.0. This is on 11.3-STABLE and with kde5/plasma desktop.

See also upstream bug report https://bugzilla.mozilla.org/show_bug.cgi?id=1623517
Comment 1 Tobias Kortkamp freebsd_committer 2020-03-22 12:07:11 UTC
I believe that this is a bug in x11-themes/plasma5-breeze-gtk instead of Firefox.
No checkboxes and radio buttons for me either with plasma5-breeze-gtk-5.18.3,
but it works as intended for me when I downgrade it to 5.17.5.

Are the checkboxes in `gtk3-demo --run=panes` visible for you?
Comment 2 Tobias C. Berner freebsd_committer 2020-03-22 14:55:39 UTC
Moin moin 

Yes, you can also verify the issue when going to systemsettings and checking the Gtk3 preview:

https://people.freebsd.org/~tcberner/images/gtk3.png




mfg Tobias
Comment 3 Tobias C. Berner freebsd_committer 2020-03-22 15:08:59 UTC
Add related ustream bug
Comment 4 Tobias C. Berner freebsd_committer 2020-03-22 15:10:01 UTC
(In reply to Tobias C. Berner from comment #3)
Apparently graphics/librsvg2 should be updated, which may resolve the issue
Comment 5 Tobias Kortkamp freebsd_committer 2020-03-22 15:33:22 UTC
(In reply to Tobias C. Berner from comment #4)
I'm using librsvg2-rust-2.48.0 here and still have the problem though.
Comment 6 Tobias Kortkamp freebsd_committer 2020-03-22 15:36:11 UTC
Also linking to that old review for switching USES=gnome over to librsvg2-rust.
Comment 7 Serge Volkov 2020-03-22 16:57:57 UTC
I have the same issue if I setup GTK2-Design to "Breeze" and GTK3-Design to "Breeze". But if I set other values, then the problem does not occur. For example, for GTK2-Design I have assigned "QtCurve" and for GTK3-Design I have assigned "Default". See screenshot:

http://www.ulbsd.ru/devel/gtk.png
Comment 8 timon 2020-03-24 00:36:12 UTC
I use the following fast patch to solve this problem (and fixed pkg-plist):
$ cat x11-themes/plasma5-breeze-gtk/files/patch-src_build__theme.sh
--- src/build_theme.sh.orig     2020-02-27 10:16:43 UTC
+++ src/build_theme.sh
@@ -109,4 +109,4 @@ fi
 
 render_theme "${COLOR_SCHEME}" "${THEME_NAME}" "${INSTALL_TARGET}" "${COLOR_SCHEME_ROOT}/Breeze.colors"
 [ -z "${INSTALL_TARGET}" ] && INSTALL_TARGET="${HOME}/.local/share/themes/${THEME_NAME}"
-cp -r assets/ "${INSTALL_TARGET}"
+cp -r assets/ "${INSTALL_TARGET}/assets"
Comment 9 Tobias Kortkamp freebsd_committer 2020-03-24 06:15:18 UTC
Created attachment 212668 [details]
plasma5-breeze-gtk.diff

(In reply to timon from comment #8)
Works for me.  Thanks.  Attaching this as a proper patch.

Problem seems to be that GNU cp -r behaves differently than our cp(1) here and
the maybe more correct fix is to use

cp -r assets "${INSTALL_TARGET}"

instead without the / suffix after "assets".
Comment 10 Tobias C. Berner freebsd_committer 2020-03-25 19:47:40 UTC
Comment on attachment 212668 [details]
plasma5-breeze-gtk.diff

Looks good to me. Feel free to commit it.

mfg Tobias
Comment 11 Bengt Ahlgren 2020-03-25 20:09:08 UTC
(In reply to Tobias C. Berner from comment #3)
Isn't is this one?
Comment 12 Bengt Ahlgren 2020-03-25 20:11:49 UTC
(In reply to Bengt Ahlgren from comment #11)
Hmm, that wasn't so useful...  Sorry for the noise - thanks for fixing!
Comment 13 Bengt Ahlgren 2020-03-25 20:26:57 UTC
(In reply to Tobias Kortkamp from comment #1)
No, checkboxes in gtk3-demo are not visible!
Comment 14 Serge Volkov 2020-03-25 22:39:08 UTC
I rebuilt plasma5-breeze-gtk with patches from plasma5-breeze-gtk.diff. And it looks good to me too. Thanks!
Comment 15 commit-hook freebsd_committer 2020-03-26 04:52:06 UTC
A commit references this bug:

Author: tobik
Date: Thu Mar 26 04:51:42 UTC 2020
New revision: 529162
URL: https://svnweb.freebsd.org/changeset/ports/529162

Log:
  x11-themes/plasma5-breeze-gtk: Fix invisible radio buttons and checkboxes

  Their assets were not installed in the right place due to differences
  between our cp and GNU cp.

  - While here add NO_ARCH

  PR:		244970
  Submitted by:	timon@timon.net.nz
  Reported by:	Bengt Ahlgren <bengta@sics.se>
  Approved by:	kde (tcberner)

Changes:
  head/x11-themes/plasma5-breeze-gtk/Makefile
  head/x11-themes/plasma5-breeze-gtk/files/
  head/x11-themes/plasma5-breeze-gtk/files/patch-src_build__theme.sh
  head/x11-themes/plasma5-breeze-gtk/pkg-plist