Bug 244983 - sysutils/py-glances: Update to 3.1.4
Summary: sysutils/py-glances: Update to 3.1.4
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Muhammad Moinur Rahman
URL:
Keywords: buildisok, needs-qa
Depends on:
Blocks:
 
Reported: 2020-03-22 18:59 UTC by Muhammad Moinur Rahman
Modified: 2020-03-24 03:30 UTC (History)
2 users (show)

See Also:
gasol.wu: maintainer-feedback+


Attachments
Update version 3.1.4 (865 bytes, patch)
2020-03-22 18:59 UTC, Muhammad Moinur Rahman
no flags Details | Diff
Update version 3.1.4 (1.77 KB, patch)
2020-03-23 19:09 UTC, Muhammad Moinur Rahman
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Muhammad Moinur Rahman freebsd_committer 2020-03-22 18:59:54 UTC
Created attachment 212618 [details]
Update version 3.1.4
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-22 23:48:09 UTC
^Triage: Reporter is committer, assign accordingly
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-22 23:53:46 UTC
Package installs files/scripts into non python specific locations [1] but the port doesnt use concurrent to make these concurrent installation safe. Add USE_PYTHON=concurrent and verify pkg-plist

Package also provides a test suite [2], would be great to add TEST_DEPENDS and a test target to improve QA substantially.

Package only declares and tests against 2.7 and 3.6, verify tests pass on versions > 3.6 else limit version support to -3.6. If it passes on > 3.6 ask upstream to test against these versions

[1] setup.py:entry_points={"console_scripts": ["glances=glances:main"]},
[2] setup.py:test_suite="unitest.py",
Comment 3 Automation User 2020-03-23 01:00:09 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/128609246
Comment 4 Muhammad Moinur Rahman freebsd_committer 2020-03-23 19:09:23 UTC
Created attachment 212651 [details]
Update version 3.1.4

comment # 2
Fixed accordingly
http://pdr.bofh.network/data/latest-per-pkg/py27-glances/3.1.4/