Bug 245042 - mail/postfix - pkg post install instructions
Summary: mail/postfix - pkg post install instructions
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Olli Hauer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-25 03:13 UTC by Phil Biggs
Modified: 2020-06-17 16:35 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ohauer)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Biggs 2020-03-25 03:13:26 UTC
I recently did two new fresh installs of 12.1-RELEASE and then pkg installed postfix 3.4.9,1 on each of them.

At the end of the pkg installs the following message displays:

To use postfix instead of sendmail:
- clear sendmail queue and stop the sendmail daemons

Run the following commands to enable postfix during startup:
- sysrc postfix_enable="YES"
- sysrc sendmail_enable="NONE"

If postfix is *not* already activated in /usr/local/etc/mail/mailer.conf
- mv /usr/local/etc/mail/mailer.conf /usr/local/etc/mail/mailer.conf.old
- install -m 0644 /usr/local/share/postfix/mailer.conf.postfix /usr/local/etc/mail/mailer.conf

No problem with the first two paragraphs but the directory /usr/local/etc/mail does not exist, either before or after the pkg install.

Should that last paragraph read:

If postfix is *not* already activated in /etc/mail/mailer.conf
- mv /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- install -m 0644 /usr/local/share/postfix/mailer.conf.postfix /etc/mail/mailer.conf
Comment 1 Phil Biggs 2020-03-31 06:21:11 UTC
I have just realized that I ran the pkg install from an ESXi console and this part of the post-install instructions had scrolled off the top:

===============================================================
Postfix was *not* activated in /usr/local/etc/mail/mailer.conf! 

To finish installation run the following commands:

  mkdir -p /usr/local/etc/mail
  install -m 0644 /usr/local/share/postfix/mailer.conf.postfix /usr/local/etc/mail/mailer.conf
===============================================================

Apologies for the noise.
Comment 2 Olli Hauer freebsd_committer 2020-06-17 16:35:19 UTC
sorry for delay,
since you found the solution I'll close the request