Bug 245053 - UPDATING: Fix net-im/prosody entry
Summary: UPDATING: Fix net-im/prosody entry
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Li-Wen Hsu
URL:
Keywords: easy
Depends on:
Blocks:
 
Reported: 2020-03-25 14:47 UTC by Thomas Morper
Modified: 2020-11-05 09:30 UTC (History)
1 user (show)

See Also:
lwhsu: merge-quarterly-


Attachments
fixing instructions in UPDATING (454 bytes, patch)
2020-03-25 14:47 UTC, Thomas Morper
thomas: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Morper 2020-03-25 14:47:18 UTC
Created attachment 212701 [details]
fixing instructions in UPDATING

A recent update to net-im/prosody changed the location of Prosody's data directory and included instructions in UPDATING on how to copy existing data to the new location. However, once the package has been installed a new, empty data directory already exists and the "cp" call won't work as intended.

The attached patch contains an updated "cp" call that should work regardless of whether the target directory exists or not.

QA: none, as it does not affect any builds.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-04-11 01:05:58 UTC
^Triage: 

- MAINTAINER reset in ports r530944, reset assignee
Comment 2 commit-hook freebsd_committer 2020-11-05 09:28:47 UTC
A commit references this bug:

Author: lwhsu
Date: Thu Nov  5 09:28:28 UTC 2020
New revision: 554125
URL: https://svnweb.freebsd.org/changeset/ports/554125

Log:
  Fix UPDATING 20200210 net-im/prosody entry

  PR:		245053
  Submitted by:	Thomas Morper <thomas@beingboiled.info>

Changes:
  head/UPDATING
Comment 3 Li-Wen Hsu freebsd_committer 2020-11-05 09:30:09 UTC
Committed, thanks! No MFH needed because UPDATING file doesn't affect package content. If we want package user notified, a pkg-message is needed.