Bug 245065 - How to update net/lualdap version
Summary: How to update net/lualdap version
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-25 21:45 UTC by Goran Mekić
Modified: 2020-07-01 07:34 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (pf)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Goran Mekić 2020-03-25 21:45:12 UTC
As stated in https://issues.prosody.im/1516 there are issues with lualdap versions < 1.2.5, and the latest version on luaforge is 1.1.0. On top of that, there are problems with config: https://github.com/lualdap/lualdap/blob/master/config. If I were to write update for this port, what would  be best way to do it? I was thinking about GH_* vars in Makefile, but please advise.
Comment 1 Li-Wen Hsu freebsd_committer 2020-07-01 07:34:26 UTC
https://github.com/lualdap/lualdap/releases has a 1.2.5 release so I think it's fine to have a patch with it. If config has issues you can have a local patch for it but it is strongly suggested to submit to upstream.