Bug 245072 - pkg.freebsd.org resolves to south africa from germany
Summary: pkg.freebsd.org resolves to south africa from germany
Status: Closed Works As Intended
Alias: None
Product: Services
Classification: Unclassified
Component: FTP/WWW Sites & Mirrors (show other bugs)
Version: unspecified
Hardware: Any Any
: --- Affects Only Me
Assignee: FreeBSD Mirror Admin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-26 11:54 UTC by noah.bergbauer
Modified: 2020-03-26 16:36 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description noah.bergbauer 2020-03-26 11:54:53 UTC
On all our servers in Germany, I am seeing pkg.freebsd.org resolve to 196.10.53.168 which is pkg0.jinx.freebsd.org in south africa. Naturally, the connection is very slow. pkg0.bme.freebsd.org (UK) would be a much closer mirror.
Comment 1 noah.bergbauer 2020-03-26 12:41:55 UTC
I also think it's incorrect that the response headers are set to uncacheable (using both Expires and Cache-Control) given that all the packages are actually cacheable forever and the index files are a perfect candidate for If-Modified-Since.
Comment 2 Sean Bruno freebsd_committer 2020-03-26 16:08:04 UTC
You are seeing an outtage/impacted mirror failover event.  Services are being routed to JINX as our continental EU mirror is not operational at this time.  Thank you for the report.
Comment 3 noah.bergbauer 2020-03-26 16:36:22 UTC
Thank you for the quick response. Sorry about the false alarm. I just jumped to this conclusion because I've been seeing stuck and very slow (<100KB/s) downloads for weeks now.

What about the cache headers though? I configured our cache to ignore them now, but that's hardly ideal.