Bug 245117 - x11/sddm: Home directory should be under /var
Summary: x11/sddm: Home directory should be under /var
Status: Closed DUPLICATE of bug 244756
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-27 23:11 UTC by Jonathan Chen
Modified: 2020-03-28 07:59 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Chen 2020-03-27 23:11:39 UTC
The entry for sddm in /usr/ports/UIDs has $HOME=/usr/local/etc/sddm/home.

I believe this is incorrect as sddm uses $HOME to store state instead of configuration; and hier(7) suggests that /usr/local/etc should only have configuration files instead of transient files. sddm  modifies the contents of $HOME whenever someone logs in/out.

I would suggest its $HOME be relocated to /var/sddm.
Comment 1 Tobias C. Berner freebsd_committer 2020-03-28 07:59:30 UTC

*** This bug has been marked as a duplicate of bug 244756 ***