Bug 245247 - cad/PrusaSlicer: update to 2.2.0
Summary: cad/PrusaSlicer: update to 2.2.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-01 18:31 UTC by teodorsigaev@gmail.com
Modified: 2020-04-05 17:30 UTC (History)
3 users (show)

See Also:


Attachments
full cad/PrusaSlicer directory (16.06 KB, application/gzip)
2020-04-01 18:31 UTC, teodorsigaev@gmail.com
no flags Details
Diff to previous version of cad/PrusaSlicer (16.58 KB, patch)
2020-04-01 18:32 UTC, teodorsigaev@gmail.com
no flags Details | Diff
full cad/PrusaSlicer directory (16.06 KB, application/gzip)
2020-04-01 18:46 UTC, teodorsigaev@gmail.com
teodorsigaev: maintainer-approval+
Details
Diff to previous version of cad/PrusaSlicer (16.57 KB, patch)
2020-04-01 18:46 UTC, teodorsigaev@gmail.com
teodorsigaev: maintainer-approval+
Details | Diff
Makefile patch adds RUN_DEPENDS (480 bytes, patch)
2020-04-05 15:46 UTC, teodorsigaev@gmail.com
teodorsigaev: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description teodorsigaev@gmail.com 2020-04-01 18:31:54 UTC
Created attachment 212943 [details]
full cad/PrusaSlicer directory

Update to recently released PrusaSlicer v2.2.0.

New version uses CGAL library but requires a fresh version at least 5.0, and current math/cgal port is too old even in 4 major version. New version of library onlike previous ones is implemented as only header source code, so, I'm afraid, I 'm not able to fix other programs depended on math/cgal. For these two reasons CGAL library is compiled in PrusaSlicer. That's why Makefile contain non-trivial pre-build target.

Also authors of PrusaSlicer didn't include hidapi implementation over libusb, so I was forced to add libusb hidapi implementation with the same version as all other hidapi functions. 

Hope, that isn't a reason to reject update.
Comment 1 Bugzilla Automation freebsd_committer 2020-04-01 18:31:54 UTC
Maintainer informed via mail
Comment 2 teodorsigaev@gmail.com 2020-04-01 18:32:53 UTC
Created attachment 212944 [details]
Diff to previous version of cad/PrusaSlicer
Comment 3 teodorsigaev@gmail.com 2020-04-01 18:46:10 UTC
Created attachment 212946 [details]
full cad/PrusaSlicer directory

The same, but it contains a fixes after portlint check
Comment 4 teodorsigaev@gmail.com 2020-04-01 18:46:46 UTC
Created attachment 212947 [details]
Diff to previous version of cad/PrusaSlicer

The same, but it contains a fixes after portlint check
Comment 5 Maciej Pasternacki 2020-04-03 11:26:44 UTC
I can confirm this package to work. Had some issues with importing new filament profiles and keeping my custom ones, but this is likely a quirk of the slicer itself rather than issue with the port.
Comment 6 Fernando Apesteguía freebsd_committer 2020-04-03 12:08:53 UTC
^Triage: Please set the maintainer-approval attachment flag (to +) on patches for ports you maintain to signify approval :-)

Attachment -> Details -> maintainer-approval [+]

Also, to avoid confusion, could you mark as obsolete the old patches and leave only the relevant ones?
Comment 7 commit-hook freebsd_committer 2020-04-05 11:57:16 UTC
A commit references this bug:

Author: mr
Date: Sun Apr  5 11:46:18 UTC 2020
New revision: 530770
URL: https://svnweb.freebsd.org/changeset/ports/530770

Log:
  Update to 2.2.0

  PR:		245247
  Submitted by:	teodorsigaev@gmail.com

Changes:
  head/cad/PrusaSlicer/Makefile
  head/cad/PrusaSlicer/distinfo
  head/cad/PrusaSlicer/files/patch-CMakeLists.txt
  head/cad/PrusaSlicer/files/patch-src-avrdude-libavrdude.h
  head/cad/PrusaSlicer/files/patch-src-slic3r-GUI-GUI_App.cpp
  head/cad/PrusaSlicer/files/patch-src-slic3r-GUI-GUI_Utils.cpp
  head/cad/PrusaSlicer/files/patch-src-slic3r-GUI-GUI_Utils.hpp
  head/cad/PrusaSlicer/files/patch-src_avrdude_libavrdude.h
  head/cad/PrusaSlicer/files/patch-src_hidapi_CMakeLists.txt
  head/cad/PrusaSlicer/files/patch-src_hidapi_libusb_hid.c
  head/cad/PrusaSlicer/pkg-plist
Comment 8 Thierry Thomas freebsd_committer 2020-04-05 12:24:54 UTC
(In reply to commit-hook from comment #7)

This port use gmp and mpfr as BUILD_DEPENDS.

Are you sure that it links with the satic libraries, and does not need the dynamic ones?
Comment 9 teodorsigaev@gmail.com 2020-04-05 14:33:25 UTC
mr: Thank you!

Thierry Thomas:
You are right, my miss
zorg% ldd /usr/local/PrusaSlicer/bin/prusa-slicer | grep gmp
        libgmp.so.10 => /usr/local/lib/libgmp.so.10 (0x801684000)
zorg% ldd /usr/local/PrusaSlicer/bin/prusa-slicer | grep mpfr
        libmpfr.so.6 => /usr/local/lib/libmpfr.so.6 (0x801706000)

Will fix soon. Should I add new bug report or post patch here?
Comment 10 teodorsigaev@gmail.com 2020-04-05 15:46:21 UTC
Created attachment 213095 [details]
Makefile patch adds RUN_DEPENDS

Add new libraries as RUN_DEPENDS, previously they are wrongly marked as BUILD_DEPENDS only.
Comment 11 commit-hook freebsd_committer 2020-04-05 16:32:34 UTC
A commit references this bug:

Author: mr
Date: Sun Apr  5 16:31:36 UTC 2020
New revision: 530795
URL: https://svnweb.freebsd.org/changeset/ports/530795

Log:
  Fix RUN_DEPENDS

  PR:		245247
  Submitted by:	teodorsigaev@gmail.com
  Reported by:	thierry@

Changes:
  head/cad/PrusaSlicer/Makefile
Comment 12 teodorsigaev@gmail.com 2020-04-05 16:36:16 UTC
Thank you very much!
Comment 13 teodorsigaev@gmail.com 2020-04-05 17:30:24 UTC
All patches are committed.