Bug 245274 - devel/mdds: update to 1.5.0
Summary: devel/mdds: update to 1.5.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-office (Nobody)
URL: https://gitlab.com/mdds/mdds/-/tags/1...
Keywords: patch
Depends on:
Blocks: 245276
  Show dependency treegraph
 
Reported: 2020-04-02 08:23 UTC by Charlie Li
Modified: 2020-06-16 22:00 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments
mdds-1.5.0 (981 bytes, patch)
2020-04-02 08:23 UTC, Charlie Li
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Charlie Li 2020-04-02 08:23:30 UTC
Created attachment 212972 [details]
mdds-1.5.0

1.6.0 is available, but LibreOffice 6.4 explicitly requires 1.5.
Comment 1 Li-Wen Hsu freebsd_committer 2020-04-03 04:15:08 UTC
Thanks for the patch. This has been included in my WIP repository: https://github.com/lwhsu/freebsd-ports-libreoffice/tree/master/devel/mdds
Comment 2 Mikhail Teterin freebsd_committer 2020-04-05 00:02:44 UTC
Unfortunately, this breaks graphics/libetonyek01, which currently insists on mdds-1.4.

Even if I relax the requirement set in the libetonyek01-port:

--- Makefile    (revision 530729)
+++ Makefile    (working copy)
@@ -14,7 +14,7 @@
 LICENSE=       MPL20
 LICENSE_FILE=  ${WRKSRC}/COPYING
 
-BUILD_DEPENDS= ${LOCALBASE}/include/mdds-1.4/mdds/global.hpp:devel/mdds \
+BUILD_DEPENDS= ${LOCALBASE}/include/mdds-*/mdds/global.hpp:devel/mdds \
                ${LOCALBASE}/include/glm/glm.hpp:math/glm
 LIB_DEPENDS=   libboost_filesystem.so:devel/boost-libs \
                librevenge-0.0.so:textproc/librevenge \

the port's configure breaks later:
===>   libetonyek01-0.1.9_5,1 depends on file: /opt/include/mdds-1.5/mdds/global.hpp - found
===>   libetonyek01-0.1.9_5,1 depends on file: /opt/include/glm/glm.hpp - found
===>   libetonyek01-0.1.9_5,1 depends on executable: gmake - found
===>   libetonyek01-0.1.9_5,1 depends on package: pkgconf>=1.3.0_1 - found
===>   libetonyek01-0.1.9_5,1 depends on file: /opt/bin/ccache - found
===>   libetonyek01-0.1.9_5,1 depends on shared library: libboost_filesystem.so - found (/opt/lib/libboost_filesystem.so)
===>   libetonyek01-0.1.9_5,1 depends on shared library: librevenge-0.0.so - found (/opt/lib/librevenge-0.0.so)
===>   libetonyek01-0.1.9_5,1 depends on shared library: liblangtag.so - found (/opt/lib/liblangtag.so)
===>   libetonyek01-0.1.9_5,1 depends on shared library: libxml2.so - found (/opt/lib/libxml2.so)
===>  Configuring for libetonyek01-0.1.9_5,1
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
...
checking for MDDS... no
configure: error: Package requirements (mdds-1.4) were not met:

Package 'mdds-1.4', required by 'virtual:world', not found

This needs to be taken care of -- especially, because libetonyek01 itself is also required by libreoffice.
Comment 3 Li-Wen Hsu freebsd_committer 2020-04-05 06:36:45 UTC
(In reply to Mikhail Teterin from comment #2)
I think this is the complete patch for  graphics/libetonyek01:
https://github.com/lwhsu/freebsd-ports-libreoffice/commit/366de8ff6ff96df2c558303e494fc5c6a841d44a
Comment 4 Li-Wen Hsu freebsd_committer 2020-04-05 06:45:07 UTC
Comment on attachment 212972 [details]
mdds-1.5.0

Latest WIP: https://github.com/lwhsu/freebsd-ports-libreoffice/tree/master/devel/mdds
Comment 5 Li-Wen Hsu freebsd_committer 2020-06-16 22:00:43 UTC
http://svnweb.freebsd.org/changeset/ports/538638