Bug 245298 - graphics/alembic: 1.7.12 fails to build when 1.7.11 is installed: error: use of undeclared identifier 'kDCCFPSKey'
Summary: graphics/alembic: 1.7.12 fails to build when 1.7.11 is installed: error: use ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Alexey Dokuchaev
URL: https://github.com/alembic/alembic/is...
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-04-02 21:54 UTC by VVD
Modified: 2020-04-03 08:39 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (danfe)
koobs: merge-quarterly?


Attachments
Build log with error (53.68 KB, text/plain)
2020-04-02 23:13 UTC, VVD
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description VVD 2020-04-02 21:54:01 UTC
portmaster alembic-1.7.11_2
…
/tmp/work/usr/ports/graphics/alembic/work/alembic-1.7.12/lib/Alembic/Abc/ArchiveInfo.cpp:66:29: error: use of undeclared identifier 'kDCCFPSKey'
     oDCCFPS = atof( md.get( kDCCFPSKey ).c_str() );
                            ^
1 error generated.

but this work fine:
pkg delete -yf alembic-1.7.11_2 && portmaster alembic-1.7.11_2
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-04-02 22:28:30 UTC
@Reporter Could you please attach a full build log, compressed if necessary, thank you!
Comment 2 Tatsuki Makino 2020-04-02 23:04:32 UTC
This is due to a problem with the -Idir order.
-I/usr/local/include -Ilib is used, so the older ArchiveInfo.h takes precedence.
There is no kDCCFPSKey in the old one.
Comment 3 VVD 2020-04-02 23:13:09 UTC
Created attachment 212996 [details]
Build log with error
Comment 4 Matthias Andree freebsd_committer 2020-04-03 00:00:05 UTC
danfe@, the link_directory path may also be an issue when fixing this
Comment 5 Alexey Dokuchaev freebsd_committer 2020-04-03 06:35:36 UTC
koobs@, asking for the log upfront makes little sense, unless the problem is hard to reproduce or something; otherwise it just clutters Bugzilla.
Comment 6 commit-hook freebsd_committer 2020-04-03 08:26:50 UTC
A commit references this bug:

Author: danfe
Date: Fri Apr  3 08:16:30 UTC 2020
New revision: 530474
URL: https://svnweb.freebsd.org/changeset/ports/530474

Log:
  Unbreak the build when previous version of the port is installed by
  preventing system-wide include directories being injected into the
  global CMake state and thus taking precedence over target's include
  directories.  Hook provided test suite to our framework while here.

  PR:	245298

Changes:
  head/graphics/alembic/Makefile
  head/graphics/alembic/files/patch-CMakeLists.txt
  head/graphics/alembic/files/patch-lib_Alembic_AbcCoreHDF5_Tests_CMakeLists.txt
Comment 7 Alexey Dokuchaev freebsd_committer 2020-04-03 08:39:48 UTC
Thanks for the report, should be fixed in ports r530474.  Patch submitted upstream (see the URL).